WE826 with MC7354 did not work with Sprint

I have a Sprint business account with Static IP service.

MC7354 with WE826 doesn’t not run. Router WE826 has GoldenOrb. APN settings: “n.ispsn”. The MC7354 sees the SIM-card because it can show me on the screen the SIM-card ID, but no phone number was recognised assigned to the SIM-card.

I also was trying to test it with Verizon SIM-card: it did not work as well. The modem recognised the SIM-card and shew me on screen phone number assigned to the SIM-card but no web-traffic. I tried two APN settings: “vzwinternet” and “internet” - both did not work.

On Sprint you should be using a Sprint PRI and FW.
Did you switch the FW to Verizon before testing with a Verizon SIM card?

I am not sure what is “PRI”, “FW” and “at!priid”. Can you, please, explain a bit about that.

FW-> modem firmware
PRI-> modem carrier configuration

can you collect the followings from the modem’s AT channel?


Manufacturer: Sierra Wireless, Incorporated
Model: MC7354
Revision: SWI9X15C_05.05.58.00 r27038 carmd-fwbuild1 2015/03/04 21:30:23
MEID: 35354706046312
ESN: 12810462629, 809FA5A5


PRI Part Number: 9903437
Revision: 05.03
Carrier PRI: 9999999_9902574_SWI9X15C_05.05.58.00_00_GENNA-UMTS_005.025_002

+CGDCONT: 1,“IPV4V6”,“n.ispsn”,“”,0,0


Current Time: 7208Temperature: 37
Bootup Time: 0Mode: ONLINE
System mode: WCDMA PS state: Not attached
WCDMA band: WCDMA 850
WCDMA channel: 1087
WCDMA L1 state:L1M_PCH_SLEEP LAC: 11B0 (4528)
RRC state: DISCONNECTED Cell ID: 0D721159 (225579353)
RxM RSSI C0: -95RxD RSSI C0: -106
RxM RSSI C1: -106RxD RSSI C1: -106

This modem was provisioned with Generic configuration (PRI)

you need to upgrade the FW to Sprint:

Sprint normally uses “otasn” on PDN1 but is is only used by Sprint for over the air provisioning.
Data “n.ispsn” is on PDN3. FW upgrade should take care of that.

I understood. Will try to upgrade firmware and let you know about my results. Thanks for you help.

I did not find a way to upgrade firmware via router. Is it the only one way to do that by mini PCI-e to USB adapter on PC?

If the platform doesn’t support upgrades then yes.

Got issues with upgrading: when I execute 9999999_9902350_SWI9X15C_05.05.63.01_00_SPRINT_005.037_000.exe it shows this:

Please check if you have the drivers installed properly on the PC and if the Sierra Wireless network interfaces (Device Manager -> Network adapters) and AT (Device Manger -> Modems),NMEA,DM ports (Device Manger -> Ports) show up.
Latest windows drivers are here https://source.sierrawireless.com/resources/airprime/software/airprime-em_mc-series-windows-drivers-qmi-build-latest-release/

I did not proceed my efforts to upgrade firmware on modem for a while, because I just did not have time for that. 4 weeks later (today) I just reinserted back to the router WE826 my MC7354 to the mini PCI-e slot and tried to make it work with Verizon SIM-card.

It did not work at all. It even did not read SIM IMSI. Looks like it did not recognize inserted SIM-card. I would be happy if any one could help me. I can pay for professional help if needed.

Hi Setonica

I’m not sure I understand where you have connected the modem. To the PC or to WE826? Are you seeing the issue on Windows or Linux? Please reach out to your Sierra Wireless support person or your distributor and they will be happy to help you. Thanks

Thank you all for replies. I have solved my issue.