Wavecom Fastrack GPRS modem with Pocket PC Device


#1

Hi.

I am currently trying to make a GPRS connection from an Intermec Pocket PC 2003 device, connecting via the serial port on the cradle.

Intermec have informed me that to connect this way with any serial modem (they have not used this specific modem) you should simply do the following:

  • Go to Start->Settings->Connections->Connections
  • Tap “Add a new modem connection” under My ISP
  • Enter a name then select “Hayes Compatible on COM1:” and tap Next
  • Enter phone number as *99# and tap Next
  • Enter username & password (& domain if required) as specified by network operator
  • Tap Advanced…
  • Select baud rate. This is typically 115200 for a modem connected via serial port.
  • Enter following dial string, replacing “your.apn.here” with APN as specified by network operator. Note there is no leading AT.

+CGDCONT=1,“IP”,“your.apn.here”

  • Default port settings are 8-N-1 with h/w flow control. This is typically what is requried, but check with modem manual.
  • Also TCP/IP and Servers are left as default (dynamic) but can be set if required
  • Tap OK to close Advanced settings, then tap Finish to save connection.

However, this does not work. (Unable to connect for an unknown reason dialog).

  • Are these modems Hayes Compatible?
  • Are there drivers available for PPC that I am missing?
  • Has anyone successfully used one of these modems with PPC?

Our supplier has suggested that we write our own firmware for the modems, which is a route we don’t want to go down.

Thanks.


#2

Is this their entry for the World’s Least Helpful Diagnostic contest?! :unamused:

Surely, there must be some diagnostics somewhere that show exactly what the PPC sent to the modem, what it received from the modem, and where the problem was?!
(like Windoze has a logging option on the ‘Diagnostics’ tab of the Modem Properties)

Yes - with the standard GSM extensions, and some Wavecom-specific extensions.

Are you sure that the speed, etc, are correctly set?


#3

It’s not helpful, is it?

As an update to my original question, I have got this working with a variation of the steps I listed. i.e.:

  • set up the connection on Pocket PC as described, except do not specifiy the at+cgdcont=1,“IP”,“apn.here” in the advanced tab.
  • the connection (still as ‘Hayes Compatible on COM1’) should just supply the user name and password, and the phone no. as 99**#1.

I then stored the APN directly on the modem by issuing the command via hyperterminal.

So, I have had to do some configuration directly on the modem, but I can now control it via a phonebook entry on the device.

I’d prefer not to have to touch the modems, and supply the APN in the connection, but can’t get it to work. If anyone has any suggestions, I’d appreciate them.


#4

Did you find any diagnostics to make more sense of it?

The instructions you originally posted said not to include the “AT” command prefix - did you do that?


#5

No, i didn’t look for any diagnostics.

I was just coming back to reply that I have now got it working with the APN string in the connection setup. This is without the AT prefix, so yes, possibly that’s what I had done wrong previously.

In any case, it is now working without setup on the modem.

Except, that is, setting the baud rate to 115200 via hyperterminal, as I believe this modem will not autobaud to that rate. Am I correct?

Also, to test this all, I want to wipe all settings from the modem’s memory, but using the AT&F command doesn’t seem to do this. It doesn’t clear the APN setting anyway. Any suggestions?

Thanks.