Verizon certification modem HL7618RD

Hi!
I want to perform some tests with out equipment to pass in a Verizon certification. Well, this equipment uses a modem HL7618RD and we want to use the PDP 1 with APN VZWINTERNET.

The modem connects into the verizon network and I used the command AT+CGDCONT= 1,“IPV4V6”, “VZWINTERNET” and I got the following results:

at+cgdcont= 1,“IPV4V6”, “VZWINTERNET”
+CME ERROR: 4

the at+cgdcont? returns the following:

+CGDCONT: 1,“IPV4V6”,“VZWIMS”,"",0,0
+CGDCONT: 2,“IPV4V6”,“vzwadmin”,"",0,0,0,0,0,0
+CGDCONT: 3,“IPV4V6”,“VZWINTERNET”,"",0,0,0,0,0,0
+CGDCONT: 4,“IPV4V6”,“PDIWIDWB.GW15.VZWENTP”,"",0,0,0,0,0,0
+CGDCONT: 5,“IPV4V6”,“VZWINTERNET”,"",0,0,0,0,0,0
+CGDCONT: 6,“IPV4V6”,“VZWINTERNET”,"",0,0,0,0,0,0
OK

The verizon wants that the PDP 1 should be VZWINTERNET.

Has anyone here experienced this type of situation?

thanks,
Rafael Dias

Hi rafael.dias,

Verizon has a specific configuration, so Sierra Wireless also releases the specific firmware for Verizon customers. The CID=3 with APN=VZWINTERNET is the default Internet APN in Verizon. The APN configuration is updated on specific Verizon firmware.

By default, PDP context IP for Verizon firmware is:
• CID=1 with APN=VZWIMS is reserved for IMS in Verizon (SMS over IMS)
• CID=2 with APN=VZWADMIN is reserved for Verizon Administration (SIM provision, OMADM, etc.)
• CID=3 with APN=VZWINTERNET is the default Internet APN in Verizon
• CID=4 with APN=VZWAPP is the default application APN in Verizon

AT+CGDCONT?
+CGDCONT: 1,“IPV4V6”,“VZWIMS”,"",0,0

+CGDCONT: 2,“IPV4V6”,“vzwadmin”,"",0,0,0,0,0,0

+CGDCONT: 3,“IPV4V6”,“VZWINTERNET”,"",0,0,0,0,0,0

+CGDCONT: 4,“IPV4V6”,“VZWAPP”,"",0,0,0,0,0,0

OK

Please find the log file as an attachment for your reference. CGDCONT.txt (962 Bytes)

You cat get it here AirPrime HL7618RD VZW Firmware_V1.10 (sierrawireless.com)

Help to tick “Solutions” if your question is answered.

1 Like

Hi Donald,

the modem firmware version that we have in our product is the same you recommended:

RHL7618RD.V.1.10.151600.201802201619.x7120m_1

do you have another tip?
best regards,
rafael dias

Hi rafael.dias

I don’t have any tips. Module HL7618RD can automatically register Verizon network after I updated Verizon firmware V1.10.

The PDP 1 should be the default APN VZWIMS. ( Not VZWINTERNET)

Do you have a default APN after updating Verizon firmware?

AT+CGDCONT?
+CGDCONT: 1,“IPV4V6”,“VZWIMS”,"",0,0

+CGDCONT: 2,“IPV4V6”,“vzwadmin”,"",0,0,0,0,0,0

+CGDCONT: 3,“IPV4V6”,“VZWINTERNET”,"",0,0,0,0,0,0

+CGDCONT: 4,“IPV4V6”,“VZWAPP”,"",0,0,0,0,0,0

OK
Is your module registered to the network with a default APN?

hi!

I asked the Verizon guys and I received this message:

For Device to communicate with Internet we would need VZWINTERNET as default. Whatever is the index of this APN, it has to be used for modem attach to network.

You can start from configuring the below.

AT+CGDCONT =1,“IPV4V6”,“VZWINTERNET”,"",0,0,0,0,0,0

Regards,

Srikanth

Hi rafael.dias,

Do you have a default APN after updating Verizon firmware?

the default APNs are the APNs present at the first question at this thread.

Hi rafael.dias

Please download HL7618RD firmware to module to restore module to default APN as below:
Is your module registered to the network with the default APN as below?

AT+CGDCONT?
+CGDCONT: 1,“IPV4V6”,“VZWIMS”,"",0,0

+CGDCONT: 2,“IPV4V6”,“vzwadmin”,"",0,0,0,0,0,0

+CGDCONT: 3,“IPV4V6”,“VZWINTERNET”,"",0,0,0,0,0,0

+CGDCONT: 4,“IPV4V6”,“VZWAPP”,"",0,0,0,0,0,0

OK

I’ll do that.

Just to inform, yesterday I wrote to our Sierra Wireless vendor and he answered:

please check command AT+HBHV? => AT Command Guide, page 106

For Verizon modules like HL7618RD, some PDP contexts should be by default: +HBHV: 2,0

You should try to set AT+HBHV=2,1 and then modify the AT+CGDCONT setting

The module is still shown on the Verizon site as a certified module, so it should be fine to use it.

https://opendevelopment.verizonwireless.com/design-and-build/approved-modules/module/6815

I assume that Verizon has made some changes to their preferred settings.

Also, the Verizon network might override some settings using over-the-air device management functions.

Well, I tried this command and it was possible to change the APN configuration:

+CGREG: 0
+CGREG: 2
at
OK
AT+HBHV=2,1
OK
at+cgdcont=1,“IPV4V6”,“VZWINTERNET”
OK
+CGREG: 0
+CGREG: 2
at+cgdcont?
+CGDCONT: 1,“IPV4V6”,“VZWINTERNET”,"",0,0,0,0,0,0
+CGDCONT: 2,“IPV4V6”,“vzwadmin”,"",0,0,0,0,0,0
+CGDCONT: 3,“IPV4V6”,“VZWINTERNET”,"",0,0,0,0,0,0
+CGDCONT: 4,“IPV4V6”,“VZWAPP”,"",0,0,0,0,0,0
OK

Hi @rafael.dias

Since the issue is resolved. Please help to tick “Solutions” on the answer.