USB Driver V3.822 Hangs Downloads


#1

Greetings,

I upgraded the USB driver to V3.822 and now uploading the embedded application the port hangs, and when I cancell the upload the port stops working which means all Traces stop and I cannot issue any AT commands. Does anyone know where to get the previous version of the driver? Re-installing Developer Studio does not provide the older driver.

I am using the following:
Fastrack Xtend (FXT009)
Developer Studio: 2.1.0.201108081252-R6801

Thanks,
Steven


#2

You should upgrade DS to 2.1.1 for better interworking with USB driver 3.8.2


#3

Per Daav’s suggestion I have upgrated the development enviornment. I don’t know yet if it fixes the USB driver problem for now I get the following error message when I compile:

ExtendedATApplication Plug-in Package (1.2.0.201108240841) is not providing libraries for the active toolchain: [Target] ARM EABI GCC

Any suggestion as to where to get the correct library would be most helpful.


#4

Please can you elaborate on why you have a reference to this package in an Open AT application?
This package actually doesn’t provide any library… Maybe it’s just a mistake: in this case you just need to remove the dependency in your project properties.


#5

Greetings daav,

Thanks for your suggestion. I went into the files - properties - OpenAT Application Library tab and deselected the Extended Application Library Package and that cleared up the error.

Now when I try to open the USB connection to the target, the port times out while loading element: Target information. We seem to be back to the driver. Any ideas as to how others have worked around this problem. I am running Window’s 7 and Device Manager shows the driver is working properly as Sierra Wireless COM Device (COM6). Please see attachment for Target Manager status and error messages.



#6

Problem solved by using dav_5’s suggestion as follows:

“Try AT+CMEE=0 and AT&W, and see if it fixes the problem, it did for us.”

Thanks to dav_5 and daav for their help.