Upgrading Software


#1

I upgraded the Software immage by loading it onto the server and sending it the following commands:
at+wdsi=8191
at+wdss=0,“internet”
at+wdss=1,1
The status then changes from APPLIED to DONE

When I try to upgrade it again to a new immage the status stays on APPLIED. Can you only upgradre the immage once on the demo account?


#2

Hi Philip,

There’s no limitation on the number of upgrades you can apply per device using the trial account, as far as I know.

Have you got this trial account from your distributor, or from the Dev Zone?

.Thibs.


#3

I registered the account on the dev zone.


#4

I just had a quick look at your device (xxx709):

Your first job has been finished (Done) but failed. You can see it in Device Management menu > Devices tab > Last Job column.

The details window of your device gives you more details: select your device in the list, and open the Activity log panel: it says:

  • you applied the first software update job at 9:11:13
  • the device connected to the platform at 9:11:19 and successfully downloaded the package --> EXEC COMPLETE at 9:11:35.
  • From here the device disconnects, and executes its job (unzip the package, apply it)
  • It connects to the platform 2 minutes later at 9:13:19 and report an error (503) which means that the package was either non complete or corrupted (bad transmission, most likely)
  • In those cases, the platform tries to relaunch the job, to be executed by the device the next time it will connect. But it seems something happened to the package meanwhile (deleted by you?) – error reported by the device at 9:21:09 (not found).

Your second job has never been executed, because the device did not connect until then (go to Details panel > last communication date).

Is the device off? Is the signal good enough? If your FXT009 LED is not blinking, it means your device is not attached to the network.

.Thibs.


#5

Hi Thibs.

This is what I tried now:
1.) I upgraded a new device 40741 successfully by sending the following commands:
at+wdsi=8191
at+wdss=0,“internet”
at+wdss=1,1
and confirmed the firmware was downloaded correctly and is working with sw image (CS100 V1.57.1) Job name: “New test 1” On HyperTerminal it also said +WDSI: 18, “100%” [it still says ‘Job Failed’ in the activity logs though]

2.) I then power-cycled the same device and tried to upgrade it again with sw image (CELLSWITCH 500 V1.58) Job name: “New test 2”
All that I get this time is:
+WDSI: 4
+WDSI: 8

I sent the [at+wdsi=8191 / at+wdss=0,“internet” / at+wdss=1,1] commands numerous times and all I get is +WDSI: 4 and 8

at+csq = 27,0

Do you think it might have something to do with “ald_InitApplicationVersion” ?


#6

I think I figured out what is wrong. If you upgrade a device from ‘Source Immage 1.0.0’ to the same ‘Target Immage 1.0.0’ it will not upgrade again. i.e. if you dont change the ald_InitApplicationVersion when you compile a new FW immage, the device will not upgrade from the platform again.

If you upgrade a device from ‘Source Immage 1.0.0’ to ‘Target Immage 1.0.1’ and so fourth, it will upgrade again and again.

Can we try to fix this on my account by purging the 0741 and 0709 devices. I will add them again and try to do the upgrade again.


#7

Philip,

As I said in my previous message, the device has downloaded the package (100% that you’ve seen in traces) but failed to apply it. It has reported it to the platform few minutes later at the next connection.

To verify what I’m saying, do an “ATI9” AT command on your device. You’ll see the software version running currently.

I think I’ve just figure out what is happening next after this udpate failure: when a SW or FW update fails, then all other tentatives/jobs will not been executed until you do a “Cancel Jobs” in the UI: in your device details dialog > Device Jobs tab > Cancel Jobs button

You should try that.

.Thibs.