Unable to set uart speed to 921600 bauds


#1

Hi every body!

I am trying to set the speed of the uart 2 to 921600 bauds. But over 115200 bauds the speed is not set correctly. Could you help me to solve this problem.
best regards.


#2

[quote=“mat”]
over 115200 bauds the speed is not set correctly[/qote]
What, exactly, do yo mean by that?

In what way is it “not correct”

Note that many PC COM ports do not support speeds over 115200


#3

It means it doesn’t work over 115200. i am connected with an arm chipset with embedded linux wich support 921600 bauds speed. and i receive incorrect data when i try to communicate. when i connect the arm to my computer, i can communicate with the chipset. But when i connect the q26extrem to my computer, i can’t communicate with the wismo.


#4

In fact i have to send the data received on the q26extrem to the arm chipset. But the 3g connection is faster than the uart speed. i put the data received in a queue to solve the problem but for big files, my wismo reset because i don’t have enough ram memory. i am trying to set the uart speed to 921600 bauds to solve the problem but for the moment it’s impossible. i also wanted to limit the dial speed by setting WIP_BOPT_DIAL_SPEED to the bearer but it returns me an error WIP_BERR_OPTION. I think this option is only for ppp profile. Now i am trying to read slowly on the socket but i receive more data than expected ( get methode on a http server), and i don’t have events WIP_CEV_READ or WIP_CEV_PEER_CLOSE any more. if you have an idea :mrgreen: