UDP Data Exchange on HL7588

I am looking for some help in setting up a UDP connection and getting the UDP data exchange working on an HL7588 mini card. Data exchange between embedded controller and HL7588 is using the serial data connection without hardware flow control. I can successfully configure UDP connection and can send data to a test PC but I have not been able to receive a response from the test PC on the HL7588.

I have tried two different UDP packet send and receive test applications and also tried running these test applications on physically separate computers each on physically separate LANs (at totally separate locations). Both networks have the proper UDP port forward from Internet setup and enabled on WAN/LAN router. Both successfully receive the data when sent from HL7588. Also, I have verified that both test computers can send to and receive from the other computer so I know that port forwarding is working in both directions over the Internet for the test applications on both computers. However, HL7588 has never indicated any data is received from either computer in all tests where I attempt to send a response to the HL7588.

The modem serial data shown below is the exact UDP connection configuration and send/receive AT commands that are being used and the exact modem responses for each command sent or condition encountered unless otherwise noted.

Transmitted AT commands and data are preceded with "Tx: " at the start of the line.
Normal expected command responses are preceded with "Rx: " at the start of the line.
Unsolicited command responses are preceded with "URx: " at the start of the line.
Comments are shown in parenthesis.

Not shown below are the actual terminators sent or received. All AT commands sent to modem include a carriage return (0x0D) and a linefeed (0x0A) as last two characters sent. Transmitted data does not include any additional terminating characters (i.e., no carriage return and no line feed). Both command responses and unsolicited responses from the modem include a carriage return as terminator.

After GPRS network connection has been established and modem successfully receives a valid current date/time stamp from the data network…

Tx: AT+KCNXCFG=1,“GPRS”,“orbcomm.t-mobile.com
Rx: OK
Rx: +KCNXCFG: 1,“GPRS”,“orbcomm.t-mobile.com”,"","",“IPV4”,“”,“”,“”,0
Rx: OK
Rx: OK
URx: +KCNX_IND: 1,4,1
URx: +KCNX_IND: 1,1,0
Rx: +KCGPADDR: 1,“” (Address returned here varies at times but is always constant for session.)
Rx: OK
Rx: +KCNXCFG: 1,“GPRS”,“orbcomm.t-mobile.com”,"","",“IPV4”,“”,“”,“”,2
Rx: OK
Tx: AT+KUDPCFG=1,0,4322,0
Rx: OK
URx: +KUDP_IND: 1,1
Rx: +KUDPCFG: 1,1,0,4322,0,"",0,0
Rx: OK
Tx: AT+KUDPSND=1,“”,4322,16 (Note this is only an example and is not the actual address used.)
Tx: 0123456789ABCDEF (UDP test application receives the transmitted data packet of “0123456789ABCDEF”.)
Tx: --EOF–Pattern–
Rx: OK
(Here embedded application waits for data. I manually cause UDP test application to send single data packets of “0123456789ABCDEF” to “”. I can repeat the send action from test application multiple times with no affect. I never see the “+KUDP_DATA” notification that is describe in HL7588 UDP example of the AT command reference manual.)
URx: --EOF–Pattern–

The last three received lines shown above always immediately follow “AT+KUDPRCV” command regardless of whether UDP data is sent or not sent from test application. It seems apparent from the observed behavior that some UDP setup parameter is incorrect or some crucial UDP receive steps are missing. Any idea what I am missing or not doing correctly?