TCP client +WIPCREATE issue


#1

Hi i am using wavecom modem fatrack SUPREME. I trying to commnuicate between client and server through GPRS. But it’s giving some problem.
I am using this commands.
AT+WIPCFG=1
OK
AT+WIPBR=1,6
OK
AT+WIPBR=2,6,11,“AIRTELGPRS.COM
OK
AT+WIPBR=4,6,0
OK
AT+WIPCREAT=2,1,“192.168.1.72”,5001

After that simply it’s waitting.
I am not able to communicate with server.
Can u tell me what’s the problem.


#2

Shouldn’t that “192.168” be a complete IP address?

Note also that any IP address beginning “192.168.” is private - it will not be contactable via GPRS or any other external device!

See:
wavecom.com/modules/movie/sc … ht=192+168
wavecom.com/modules/movie/sc … ht=192+168
wavecom.com/modules/movie/sc … ht=192+168


#3

“Private IP Addresses” - See:

en.wikipedia.org/wiki/Private_network

RFC1918, Address Allocation for Private Internets
tools.ietf.org/html/rfc1918

For the inacessibility of devices “behind” a NAT-enabled router, see: en.wikipedia.org/wiki/Network_ad … #Drawbacks

See also:
en.wikipedia.org/wiki/Router
en.wikipedia.org/wiki/Proxy_Server
en.wikipedia.org/wiki/Gateway_%2 … working%29