[swicwe tool] Generation error with version 1.15


#1

Hello,

I tried to use latest version 1.15 of tool “swicwe” to manage firmware images with our custom legato apps for our WP8548, downloaded from : https://source.sierrawireless.com/resources/airprime/software/swicwe/

Unfortunately I get this error with version 1.15 that I don’t have with 1.10 version, could you please, for future generations, explain this error ? :

marc-p@marcp-Latitude-E6430:~/Documents/firmware/V1.2.0/test_gen$ swicwe -o firmware.spk -c boot-yocto-legato_wp85.cwe
Parsing input file boot-yocto-legato_wp85.cwe 
 Type	 Size(Exclude Header)	 Product	 Compress	 Version
*APPL    34352729                Y912            0               Tue Mar 20 19:17:37 CET 2018
 SYST    24606925                9X15            1               Tue Mar 20 19:17:37 CET 2018
 USER    5675486                 9X15            1               Tue Mar 20 19:17:37 CET 2018
 APBL    74572                   9X15            0               Tue Mar 20 19:17:37 CET 2018
 APPS    3994146                 9X15            1               Tue Mar 20 19:17:37 CET 2018
Concatenating images
/tmp/temp.mbn doesn't exit. Please check.

ERROR: Application file /tmp/temp.mbn does not exist
Unable to create header for 'FOTO'


marc-p@marcp-Latitude-E6430:~/Documents/ucg-firmware/V1.2.0/test_gen$ swicwe

NAME
        swicwe (version 1.15) - Tool to handle CWE and SPK images

USAGE
        swicwe -P|--parse <file.cwe|file.spk>
        swicwe -c|--cat -o|--output output.spk file1.cwe file2.cwe [fileN.cwe ...]

OPTIONS
        -h, --help
                Display this message.

        --full-help
                Display help for advanced options

        -P|--parse <file.cwe|file.spk>
                Parse and display content of input CWE/SPK file

        -c|--cat
                Generate a concatenated (SPK) file from input CWE files.
                Input file names have to be specified at the end of the command line

        -o|--output <output.spk>
                Output SPK file

Thanks in advance.
Marc


#2

Marc, just to check - does /tmp exist on your system?

Also, can you try passing in the two images as components:
swicwe -o firmware.spk -c boot-yocto_wp85.cwe legato-image_wp85.cwe


#3

Hello,

Sorry for the late answer but indeed /tmp exists on my system and I tried separating images boot-yocto and legato-image and it resolved the problem with version swicwe V1.15

Thank you.