Stopping the debug from the GSM device

Hi All,

I want the use the Q2686 as a modem and not with the OpenAT OS. I turn the off the application from running, but now the device prints out a whole list of debug on startup. This takes approximately 10 seconds. Is there a way to stop this debug being output from the GSM?


What “debug”, exactly, does it produce?

If they are standard (unsolicited) AT responses - such as +WIND: and +CREG: - then the AT Commands Manual tells you how to control them…

I had the same problem before, especially after sending AT+WOPEN=3, but after reinstalling the Open AT firmware, the problem was gone. You may try it to see whether it can fix your problem. If can, I am pretty sure it is an OAT bug. Wavecom may need attension.

What I think happens is that OAT enables all these unsolicited indications internally (see ADL User Guide, “Inner AT Commands Configuration”) and, when you stop the application, it doesn’t disable them again - so they keep coming!