Starting out with the FX30S and questions abound

I am evaluating the FX30S and trying to get everything setup.

I have tried steps from several different sources but nothing seems quite right yet, so here are some questions:

1. What is the “best” method for getting set up for development for the FX30S?

I tried manually doing things like described in the mangOH_Red tutorial, but that didn’t work. I got closer by using the legato-spm tool. Then I was able to build the helloWorld app, but it didn’t run on the FX30S. The FX30S rebooted several times and then when it was stable, the app wasn’t there.

2. What are the “correct” versions of things to use with the FX30S?"

the legato-spm appears to load packages newer than those listed on I suspect that mixing versions of things won’t work well and that is why my FX30S kept rebooting.

3. How do you modify the Yocto build?

I found and tried to use “FX30_WP8548_full_R14.0.4.002.tar.gz”, but I am not sure what “image” to specify to be built. Is there any documentation for this or is there a better way to modify the Yocto Linux? I need to replace openSSL with the FIPS version.

I think that is enough questions for now.



Hi Mark,

  1. There is no one “best” method for FX30/FX30S development setup. It really depends on what you need to develop.

If you only need to develop a Legato application, then Developer Studio would be quickest and easiest. You would need to ensure you’re using the correct toolchain and building for the correct target.

If you want to modify the kernel or root file system, then you’ll likely want to use the Yocto build. (but be aware there is a way to build kernel modules via Legato as well).

As far as I know, the legato-spm tool is not up to date with the R14.0.4.002 FX30 release.

The mangOH tutorials are specific for the mangOH boards so they won’t apply directly to the FX30. We do have plans to release an Application Note to clarify some of the issues you’re experiencing with the FX30 build.

  1. The correct version to use for the FX30S is referenced by the link you provided, R14.0.4.002 with Legato version 16.10.1.m3. Note, this version of Legato is actually a maintenance branch off version 16.10.3 even though it appears to be based off 16.10.1.

Download the Source code tarfile and the Legato tarfile. Extract the Source tarfile first, then extract the Legato tarfile into main directory of the Source code. If all is done correctly, you should see a bunch of folders such as kernel, lk, meta-columbia-x and a legato folder as well (You might need to rename the legato folder to just “legato”).

You can also insert your Legato application into the legato folder of the Yocto build and have it as part of the Legato image. You can browse through the legato folders for the right location.

  1. To build the image, just type “make”
    The binary image generated is a CWE file located at:

Look for “boot-yocto-legato_wp85.cwe”. This image will contain the bootloader, kernel, RFS and Legato. The Legato image only is “legato-image.wp85.cwe”. You can also install the swicwe tool ( to parse the CWE files and view their contents.

To replace openSSL, try modifying the recipe:

Note however, it’s not good practice to edit existing recipes, it would be preferable to create an openssl.bbappend file in your own custom layer.


Thanks for all the info.

I have made some progress following your steps.

  1. I extracted the Source tarfile first
  2. then I extracted the legato tarfile into the same directory and renamed to ‘legato’ (so legato, kernel, lk are at the same level as poky)
  3. then I typed ‘make’ (and had to get a few extra tools, etc.)
  4. it all built merrily until building legato-af
  5. then I get the error “cat: modules/Columbia/apps/columbiaAtServiceComponent/columbiaAtService.c: No such file or directory” and I am unable to locate the file using ‘find’ and cannot find a directory “Columbia” either.

Is there some other code I need to get?


Hi Mark,
Please edit the file:
meta-columbia-x / meta-columbia-x-app/recipes/legato-af/legato-af_git.bbappend

And remove the entire “do_compile_append” function.


That allowed it to finish building. Thank you.
Was that needed for a previous version of Legato?

What is the difference between the “2k” and “4k” items in the directory?

Hi Mark,
No the patch was added for when the columbiaAtService source code was compiled. However, the external source code includes columbiaAtService in binary format.

The 2k and 4k refers to the flash page size. All devices will have 4k flash sizes.


Trying to setup the devstudio.

I am using

I unzipped the archive, ran devstudio, entered my name.

Now it wants me to pick a module, which I believe is the WP85XX for the FX30S.

Then it wants me to select a Legato version, none of which are the R14.0.4.002 with Legato version 16.10.1.m3. that I believe is supposed to be used with the FX30S.

So, is there a way to make the devstudio use the legato 16.10.1.m3 I already have installed?


R14.0.4.002 is not officially supported with DevStudio, but perhaps @dpochet can offer some insight.


So, my alternative at this point is to do command-line development? I know the mangOH_Red tutorial discusses that a bit, would that be a good thing to follow or is there better documentation to use for the FX30S?


Hi Mark,
We’re working to improve the documentation and FX30 support with DevStudio.

The mangOH Red tutorials will probably get you fairly well along on the FX30, but there are hardware differences. If you get stuck, feel free to ask for help.


Hi @mjbutsch ,

I had the same issues regarding the latest release R14 16.10.1.m3.

I managed to integrate it to developer studio.
For this, you have to follow these steps:

Then in the packages manager perspective (named “packages”), you have to add 2 new repositories as “folder” and add the path of the “legato-16.10.1.m3” directory and the toolchain directory (for me /opt/swi/y17-ext).

Once done, you should have the 16.10.1.m3 framework installed with its toolchain.


link for all FX30 R14 ressources: _

Hi @mjbutsch, I’m unable to get this to work. Here are the steps I used: Errors with FX30 application

Any ideas?

Hi @psiphi99,

I can’t offer any advice as I haven’t tried the suggested method to get the Developer Studio to work with FX30 versions.

I have been doing my work “old school” without it.

I decided to wait until the newer versions of things for the FX30 are available.


1 Like

I’m not alone on this planet having problems trying to develop with FX30S.

To develop with DevStudio, need to install self compiled package 16.10.1.m3. ?

Did somebody success with @benrey explanations.


I’ve loaded an old version of DevStudio with legato 16.10.1 and it seems like it works.

Nothing very simple to develop with the modem.


Hi Xavier,
We’re working to improve the FX30 development. The new release will support Leaf and Visual Studio Code. We hope to release towards Sept.

For the R14 release and DevStudio, you will indeed need to add 16.10.1.m3 support.

Personally, I prefer the yocto build environment and adding the application into the build.