Sending An SMS M1306B GSM Modem


#1

Hi, I have this Fastrack M1306B GSM Modem, to which I connected to my PC using a serial cable.

I use Windows HyperTerminal to check to see that my PC is able to communicate with the modem, and the responses are below.

AT [enter]
OK

AT+CGMI[enter]
WAVECOM MODEM
OK

AT+CSQ[enter]
+CSQ: 29,0
OK

[b]AT+CRGREG[enter - this i got from one of the posts here not really sure what this is for]
+CGREG: 0,0
OK

AT+CREG?
+CREG: 0,2
OK[/b]

Could some explain what the CREG & CGREG are meant to do, and are these the causes of me unable to send an SMS?

Also please not the LED on the GSM Modem does not blink at all, to which the User Guide stated that it should to indicate network registration & activity.

I use ActiveExperts Messaging Server v4.1 as my application to send an SMS but I would like to make sure that my modem and SIM are working.

Thanks
OJ
Please note I am very new to GSM Modem & AT Commands.


#2

The AT Commands Interface Guide describes all the available AT Commands.

The User Guide for the Fastrack also contains some examples…


#3

Hi,

Thanks for replying, and where do I get this AT Command Interface Guide?

I have followed all setup instructions of the Fasttrack User Guide and still am unable to send to Send An SMS from my GSM Modem using the Windows HyperTerminal. :blush: :question: :question:

Thanks
OJ


#4

I presume you use the command “AT+CMGS” to send the SMS? Some obvious mistakes that people make when doing this for the first time is the following:

  1. Make sure the SMS Service Centre is set correctly with the “AT+CSCA” command
  2. You must wait for the '>" character before entering the body text you want to send.
  3. Once you typed the contents of the SMS message body, you must terminate it with a character.

The “AT Commands Interface Guide” can be downloaded from the Wavecom website, I just can not remember the exact URL. Try using the search facility to look for it.


#5

Yes, I did check the SMS Service Centre Number to which it was correct.

AT+CSCA? [enter]
+CSCA: “+67572210010”,145 (correct SMS Service Centre Number)

And when I tried sending a message
AT+CMGS="+675#######" [enter]

“hello world” [CTRL + Z]

ERROR

This above is what I did and got the error message. :exclamation: :question:


#6

Do AT+CMEE=1 to enable extended error information;
this will give you more detail about the error in the form of a +CMS ERROR or +CME ERROR code.

You can look-up the meaning of the code in the AT Commands manual;
also try putting it into Google…


#7

Thanks WIll Try That and See :bulb:


#8

Well,

I went through nearly 159 pages on AT Commands, and finally got to the stage of sending an SMS:

here are my results

AT+CGSM="+67572749289"[enter]

Testing GSM Modem [CTRL + Z]

+CMS ERROr: 512

:angry: :angry: :angry:


#9

So, have you looked-up the meaning of +CMS ERROR: 512 :question:

Hint: Look in the Appendixes to the AT Commands, “Codes and Values”…

What did Goog;e say?


#10

:unamused: Hi,

After running a check on this error +CMS ERROR: 512, the answers I got stated “that it is an Error which occures when sending and receiving SMS happen at about the same time, does causing a collision.

The ATA Appendixes to AT Commands Interface Guide States "MM Establishment Failure (for SMS) which has not told me much. I don’t know what MM is referring to. And what establishment failure is this?

Some more info
AT+CREG?
+CREG: 1,2

My signal strenght is around 29 which the modem manual says is OK. The baud rate in the manual of 512.200 does not work and the modem does not respond, until I bring it down to 9600 to which the modem starts to respond. The SIM Card works OK in my phone, and has enough credits, I was able to send an SMS and make a voice call.

Please help
Thanks
OJ :exclamation: :question: :bulb: :blush: :cry: :angry:


#11

Works like a charm if you use at+cmgs instead of at+cgsm like I originally suggested.

AT+CGSM="+67572749289"[enter]

Testing GSM Modem [CTRL + Z]
+CMGS: 73


#12

For OJ: second digit code returned by AT+CREG? command goes like this:
0: not registered, ME is not currently searching for a new operator.
1: registered, home network.
2: not registered, ME currently searching for a new operator to register to.
3: registration denied.
4: unknown.
5: registered, roaming.

If you still read 0,2 or 1,2, this mans that your modem is not registered on the network.
Have you entered PIN ? Valid one ?


#13

Well, we are encountering another problem with a Fastrack Supreme.

the +creg? returns always 0,0. So we think it’s not even trying to register on the home network. Isn’t there a way to force the thing to try and register?

It is not the SIM because it is working in a normal cell phone on the same location.

Signal quality varies from 25 to 31, more than enough…
We even checked the preferred network list, all OK… :-S

If there are any hints available, please post them right away, we are getting desperate and actually wanting to throw the FS trough the window!