Reverse Telnet/SSH Access Denied Non-Functional

I have been having trouble getting the Reverse Telnet/SSH function to work to be able to use the serial port to configure a legacy serial configurable device.

Device: MP70, ALEOS 4.8.1 BLD 006

I followed the instructions in the manual that are largely similar to the following online article:

I set the serial port up as follows:

Startup mode default: Reverse Telnet SSH
Configure serial port: 115200,8N1
Left all of the other settings at their default values which are the same as shown in the above article.

I set the SSH service up with the following parameters:

Remote Login Server Mode: SSH
Remote Login Server Telnet/SSH Port> 2332
Telnet/SSH Echo: Enabled

I tried to SSH locally (connected to the MP70 switch) into the gateway ( I can establish a connection using the “user” account and the default password “12345”. I am then presented with the AT command interface. So I know the SSH service is responding properly.

login as: user
user@'s password: //12345 typed at prompt


I then tried to SSH locally using the “sconsole” username and the default password of “12345” like the manual describes however, the SSH service responds with an access denied message.

login as: sconsole
sconsole@'s password: //12345 typed at the prompt
Access denied
sconsole@'s password:

Thinking that the password may have been inadvertently set to something else, I went to the Admin page and changed the “sconsole” password to “54321” and clicked Change Password. The page stated “Password changed successfully”.

login as: sconsole
sconsole@'s password: //54321 typed at the prompt
Access denied
sconsole@'s password:

However, I still get and “access denied” at the SSH prompt when using the “sconsole” username and the new or default passwords.

Any help would be appreciated. Thanks, Derek

Hi derekyu,

I hate to be the bearer of bad news, but unfortunately, Reverse SSH is a feature that is bugged in 4.8.1. This is expected to be fixed in 4.9.0 which is right around the corner. Will you consider using Telnet instead? Of course, it’s not as secure, but it will get the job done until ALEOS 4.9.0 is out.


Thanks, I can wait for an update to ensure SSH works with the serial console. Good to know I wasn’t completely crazy.

Thanks, DY