R71


#1

I am tring to test the at comand set for the wip soft on R71 .
So after using +wopen=1 and +wipcfg=1 i reseive an error.
As far as i understood the wipsoft on r71 comes integrated with the firmware , therefore i am probebly wrong about it…


#2

Unfortunately you are wrong. WIP soft is an application that you have to download to modem. After downloading it you need to run application by command AT+WOPEN=1. For R71 it is WIP 4.x version .


#3

Hi

I am using Wavecom fast tract supreme modem. I am trying for a client server data communication using TCP. I am having dedicated IP address(static) as server. I am having an server application running on Server @ port No 2000.

I would like to use WIP commands and send the data through the GPRS from the hyper terminal.

but when i give
AT+WOPEN=1 OK
AT+WIPCFG=1
ERROR.

Why i am getting this error for the WIPCFG command??

experts pls help me.

regds
KR


#4

Hiya,

Have you downloaded the appropriate WIP application to your modem?

Is your modem enabled to use the WIP library? You can tell if it is activated by using AT+WCFM command.

Check up the doco on how to decode the +WCFM result.

If the feature is not activated, you’ll have to talk to your distributor.

Also, turn on the extended error reporting (AT+CMEE=1) - this will give an error value that you can look up in the documentation to help track down what’s going on.

cheers, Dave


#5

Hi

Thanks for your prompt reply.

I have got following reponse while executing the WCFM commds.
AT+CMEE=1
OK
AT+WCFM?
ERROR
AT+WCFM
ERROR

Could pls point an example (WIP project so that i can download and try the same?

I have taken a sample application (tcp_client) and trying to send data over GPRS to a remote static IP. But I am not able to succeed with it.SO I thought of trying the GPRS connection through the WIP AT commands.

Thanks a lot in advance.

regds
KR


#6

Hiya,

Did you check the AT command manual for the right options for the +WCFM command?

The ‘?’ option is not available on the +WCFM command. Try

AT+WCFM=5

instead. This gets the extended commercial feature set of the modem.

The modem on my desk returns the following:

AT+WCFM=5
+WCFM: 00000059,0

OK

Decoding this using the table in the AT command guide indicates the following extended commercial features are enabled:
Open AT C-GPS plug-in (0x40)
Real Time operating System (0x10)
Open AT GTI plug-in (0x08)
Internet Plug-in (0x01)

Note that all values are in HEX, so you have to use hexadecimal subtraction to work things out.

If you don’t have the Internet plug-in activated, you’ll have to go back to your distributor and get them to sort it out. Nothing more can be done until you have the Internet plug-in activated.

This looks as though the WIPsoft Application has not been downloaded to the modem The WIP AT commands (i.e. AT+WIPxxx) are an Open AT application that has to be downloaded to the modem just like any other Open AT application.

Talk to your distributor to obtain the appropriate downloadable file to install the WIPSoft application.

ciao, Dave


#7

HI

Thanks a lot.

The modem @ mt desk returns

AT+WCFM=5

+WCFM: 00000071,0

OK

what does it mean??


#8

The description is given in the AT Commands manual


#9

Hi,

I have downloaded the WIPSoft application and established the connection with the Server.I have used the following AT Commands.

AT

OK
AT+WIPCFG=1
OK
at+wipbr=1,6
OK
at+wipbr=4,6,0
OK
AT+WIPCREATE = 2,1,“xxx.xxx.48.88”,2000
OK
+WIPREADY: 2,1

From the server side I am able to connection established status. Now I would like to know how to transfer a data through AT Commands.

Thanks a lot in advance.

Could you pls help on " How to send data thrugh WIP AT Commands to the established socket?"

regds
KR


#10

I got the following error when i try to give wipdata command.

at+wipdata=2,1,1
+CME ERROR: 831 (bad state)

How to overcome this error?


#11

Hiya,

Good to see that you have got the application installed.

Section 9 of WIPAT Commands User Guide has a large number of commented examples on how to connect to the internet and transfer data using vaious methods supported by WIPSoft.

ciao, Dave


#12

Hi

Thanks for your prompt reply!!
I have given the following series of commands and received the “CONNECT” response finally.

AT+WIPCFG=1
at+wipbr=1,6
AT+WIPBR=2,6,11,“airtelgprs.com
at+wipbr=4,6,0
AT+CMEE=1
AT+WIPCREATE = 2,1,“xxx.xxx.48.88”,2000

AT+WIPDATA=2,1,1

CONNECT

But After getting “CONNECT”, What ever i am sending/receiving is data right? I have typed lot of characters but not able to see data in the server side. I have tried this may time.

More over from the WIP AT commands guide i understand that “+++” will bring out of Data mode to command mode. This is not happening for me. I am restarting the modem every time to after getting “CONNECT”, to try some other AT Commands combination.

Could pls help me to resolve

  1. How to do the data transfer between Modem and a Server Socket Running on a PC(Server with dedicated IP Address)
  2. how to come out of Data Mode to AT Mode.

regds
KR


#13

Hiya,

Cool.

Yep, you are in data transfer mode. According to my reading of the WIPAT Commands User Guide (section 6.2.7), you have started the data exchange in Continuous mode.

Once you have finished sending your data, you have to send an ETX character (0x03)to close the connection. I suspect that no data is being sent as you haven’t input enough data to fill the TX buffer.

Try sending your data followed by an ETX character and let us know how you get on. Alternatively, send a lot (4-8 kBytes or so) to fill the TX buffer and see if you get some of the data through to your PC.

That’s my reading also - but I’ve never done it this way. I’ve always sent the data and ended the transfer with the ETX character which drops me back to AT mode.

If you have a linux box as your receiving PC, netcat is your friend while developing these sorts of applications.

ciao, Dave


#14

Dear Dave,

Thanks for all you support during this application development.

I am able to transfer the data from the Modem to PC successfully. I don’t hav words to describe your support during this journey!! You are remember able person in my professional journey!! Thanks once again.

But, After entering 0x03, Connection is closed. How to complete the data transfer with out closing the connection?? Is it possible to limit the buffer size?? If so how to do it??

Thanks a lot in advance.
regds
KR


#15

Hiya,

No Problems - glad to have been of some assistance. There’s a large number of processes that all have to operate correctly at the same time for this stuff to work. It can be a bit confusing…

Cool. That counts as a sucess in my book.

Don’t know. I haven’t had to work in this manner. I had a quick look through the API doco for a ‘FLUSH’ command or similar but couldn’t see any.
You are going to have to close the ‘write’ channel anyway if you want to get anything back from the server.
I think you’re probably better to do the transfer as chunks of data rather than streaming TCP data, as I suspect you may run into issues with the GPRS network for long-running transfers. No proof of this though…

Have a look at the +WIPOPT options - there is a WIP_COPT_SND_BUFSIZE that appears to set the size of the TCP socket send buffer. Again, I haven’t used it…

ciao, Dave


#16

Dear Dave

Thanks for your reply!!

This oprion WIPCOPT_SND_BUFSIZE can be used only for Http connection.

I would like to know how to flush the data manually through the custom socket made to the Server.

After 0x03 the connection is closed. For further data transfer we need to establish the connection again. So could you pls let me know that how to flush the data in a particular socket.

This will be more helpful for me.

regds
KR


#17

Dear Dave,

WIP_COPT_SND_BUFSIZE is applicable only to HTTP socket. Think this will not be applicable to the custom socket.

i have completed my proof of concept phase. now want to implement the same using WIP API’s.

Do you have any idea like where to “getting started” for the same application.

bottom line , i would like to know how to convert all these AT Commnads into API’s and should accomplish the same using the GPRS Application running on Wirelesss CPU.

regds
KR


#18

Dear Dave,

with respect to the tcp socket communication using AT Commands and WIPSoft Application, I am able to send data only if i give 0x03 and close the socket.

Data transfer is not happening even i filled the buffer with huge data (>10Kb). DO i need to configure something in the modem to accomplish the data transfer??

Pls let me know the configuration to transfer the data immediately to the server instead of giving 0x03.

Timely response will help me a lot…

Thanks a lot in advance.

regds
KR


#19

Hiya,

What’s wrong with buffering your data, opening the socket, writing the data and then closing the socket? Sending 0x03 only closes the socket connection, not the the GPRS connection so it’s easy to set up another socket connection.

Are you sure it’s a problem at the modem end? Are you sure that your server program (and OS) is not buffering inbound data until the socket is closed? Try using netcat on a Linux box as your ‘server’ and see how the data arrives on the console.

I haven’t streamed data across a raw socket in WIPSoft. All my transfers have been done on a transaction basis using HTTP transfers.

Even when I used the OpenAT WIP API, all transfers have been done on a Open - Write - Read - Close cycle, although it looks as though you can continue to either write data continuously to a socket OR read data continuously from a socket - but not both in the same connection.

You may be able to try using two separate sockets to stream data - one for write (modem to server) and another for read (server to modem). Make sure that you are sending keep-alive data in both directions regularly, or the socket may be closed by the OS (modem or Server).

Have a look at the tcp_client sample source in the OpenAT/Plug-ins/WIP directory for a sample on how to write a TCP client to send data to a Server. I still think you’re hosed with the streaming though - this sample does the same Open - Write - Read - Close cycle that is used for HTTP transfers.

You may have to stop using the WIP library and go back to using the OpenAT GPRS and FCM API to write your own data transfer protocol. After all, WIP is just layered over these APIs anyway. I haven’t done this, although others on the forum may have.

Good Luck.

ciao, Dave


#20

i’m using raw tcp sockets and even small packets (aka 1 Byte) get send trough ok. i’m keeping the socket open for long periods of time, and using the same socket for repeated sending and receiving. i’m only sending event-style packets. no streaming.
i have no experience using the higher level functions (http etc)