Q2698 can't sent SMS during active data connection

Hi All,

I can’t sent SMS during active data connection. Without data connection SMS works without problems. I try to change AT+CGSMS to different values, but no effect. Modem firmware 7.50. Can anybody give me advice?


Using Open-AT, or AT Commands :question:

I’m using AT commands (AT+CMGS), both modes - PDU and Text.


If you’re not doing it via OpenAT, are you using the data (PPP) connection over the same port (Serial or USB) as you are trying to send the SMS commands?

As far as I am aware, the PPP data connection will take over the port - you’ll have to drop the PPP connection (using +++ with a 1 second guard time either side) to bring the modem back into command mode before trying to send the SMS using AT commands.

ciao, Dave

I use for sending sms device /dev/ttyUSB3 and for PPP connection device /dev/ttyUSB4. So I can send sms and another AT commands simultaneously with PPP connection. But when PPP connection is active I get ERROR (+CMS ERROR: 512). Also I try adl_smsSend function it works the same way. When PPP connection is active sms is not send.

Have you looked-up what that means :question:

+CMS ERROR: 512 indicate ‘MM establishment failure’

You haven’t configured SMS for delivery over GPRS, have you…?

I have not. But when I tried to configure transport service with AT+CGSMS=0 or AT+CGSMS=2 sms are completely stop working. I tryed set back to default value AT+CGSMS=1 but without effect. Now sms are not working even if PPP connection is absent.

The issue was solved by updating firmware version R7.52.0.A1.201401021703. Now sms works simultaneously whith PPP. AT+CGSMS is set to 1.

I am going to hijack this thread as I am seeing similar problems with the Q2698. First of all, igor thanks for posting that a firmware update is required to get it running, I was trying for hours and not understanding what was wrong. Now sms are sent during active data connection. At least I thought it was working, but today I tried with a different provider:

On one provider everything works like a charm, no problems with sending sms and having an active data connection. With a second provider I can send one sms and while sending the second sms (or trying) the modem just goes wild. Instead of returning valid mux packages it just returns something like the following (and doesnt stop anymore):
0x80 0x00 0x78 0x80 0x78 0x80 0x80 0x78 0x80 0xf8 0x78 0x80 0x80 0x78 0x0 0x78 0x80 0xf8 0x78 0x80 0xf8 0x78 0x78 0x78 0x80 0xf8 0x78 0x80 0x00

The weird thing is that if I reduce the size of the sms (~10 chars) it works… I have the awkward feeling that this is a bug of the module that maybe someone else has already encountered?

EDIT: I am using the UART and not the USB interface