Q2686RD: firmware upgrade from 7.47 to 7.52 doesn't work

I have a board with Q2686RD module installed with 7.47 firmware.

I upgraded the bootloader to V10c05 with success.
Next I tried to upgrade the firmware to the latest 7.52, through Developer Studio and Hyperterminal (1k-Xmodem), but after many packets I receive the error:


and the transfer of the file is interrupted. After this error the module doesn’t answer to AT+WOPEN command anymore, so I upgraded the firmware back to 7.47 through Hyperterminal.

Any suggestion how can I upgrade the firmware to 7.52?


You might have to use DWLWin and the .wpk upgrade packages.

I’m not sure if they’re available on the Developer website any more - but you should be able to get them from your Distributor/FAE.

ciao, Dave

What is the difference between the firmware upgrade through Xmodem/.dwl file and your method DWL Win/.wpk file?

I understood there are two methods for upgrade the firmware of a wireless module: Xmodem and boot mode. Xmodem mode can be used if there is already a firmware running in the flash, otherwise boot mode can be used. Boot mode doesn’t use Xmodem, but a proprietary protocol on the serial link. This proprietary protocol is implemented in the software DWLWin.

If you suggest to use DWLWin on my module, it seems you think a valid firmware isn’t running. I don’t know why, maybe a wrong previous upgrade, but initially there were really both a valid firmware and Open AT application running. How can I understand if I need to use a boot mode or I can simply use Xmodem for firmware upgrade?

Why .wpk files aren’t available in Sierra website?


The DWLWin/.wpk method appears to update both the bootloader and the firmware in the module. DWLWin also allows you to resize the A&D flash area as part of the upgrade, and I suspect (although can’t prove) DWLWin doesn’t rely on downloading the firmware to flash then ‘installing’ it as is done with the XMODEM method.

I recall that there has been a couple of threads here on the forum about people having problems moving from 7.47 to 7.52 using the XMODEM method, but being successful using DWLWin.

No, it appears that the changes from 7.47 to 7.52 sometimes confuse the XMODEM method. DWLWin will install the correct combination of bootloader and firmware (and any other ‘hidden’ parameters that are in the .wpk bundle).

Good question - and one that’s been asked before. I don’t know.

ciao, Dave

I don’t explain why this isn’t explained in Sierra documents, mostly in 7.52 release notes or similar doc.

So it seems it’s impossible to upgrade from 7.47 to 7.52 by using XMODEM method.
Sierra people, where are you? Aaaargh!!

I’m quite new with Sierra wireless modules. They are nice objects, but the documentations and support don’t seem nice as well.

I just installed Developer Studio with latest packets, so I have Open AT Application Framework (Firmware and Open AT OS

I have a board with Q2636RD mounted, but the firmware is 7.47. When I tried to download example to the module, I receive a warning about a different linking address most probably caused by a different firmware on the module. So I decided to upgrade the firmware of the module, with the results that you know.

At the contrary: could I make an application with the latest Developer Studio for a module with an older firmware? Should I download older Application Framework package from “Packages Manager”?


Yep, that’s another way around the issue. I’ve got three or four different application framework packages loaded into DevStudio to support some older projects.

ciao, Dave