Q26 not starting up if battery flat


#1

I am using a Wavecom Q2686 module. It runs of a LiIon battery, 3V7 1000mAh. The battery is connected to the Vbatt pins on the Q26. The Charge_In pins are connected to a 4V2 power supply, which may or may not be connected.
I have the following problem:
When the battery is flat, the Q26 does not start up, when the 4V2 is applied to the Charge_In pins. I have to remove the battery and charge, before I can get the Q26 to start up.
Question:
If I connect a diode from the Charge_In pin to the Vbatt pin, will the battery and/or the Q26 be damaged? This seems like a solution for when the battery is flat, and external 4V2 is applied, to get the Q26 going, and for the Q26 to charge the battery. :question:


#2

Use series resistor to limit the current drawn into the battery.


#3

Hi
Thanks for reply. Should I use diode and resistor? A 33R resistor to limit to ± 100mA? Or should I go smaller on the resistor?
Thanks!


#4

Without details of your schematics.

Use diode(s) not only to disable current in reverse direction, but also to disable overcharging the battery. Limit current to only do initial battery charge and let Quick do the real charging.


#5

OK, thanks. Will test and see what happens!


#6

Hi Gerry,

Have you been able to test ljweko’s suggestion?

Regards,
Tyrone


#7

Hello, I have the same problem, when the battery is low, and the Charger-In pin is connected to 4,2V the module is dead, the Open AT do not start and then is necessary disconnect the lithium battery and recharge externally and then when I reconnect the charged battery to Q2686, yes it start and start also the recharge algoritm in Open-AT when the Charger-In is connected to 4,2V. Is Known a solution to this problem ?

Thanks
Bye bye


#8

Good morning all,

This is a problem that we have found, and the seems to be no real solution. The way to go is to use an external charging circuit. Get hold of your disti, and ask them for an application note that Wavecom has released called “EXTERNAL BATTERY CHARGING SOLUTION - WM_DEV_MOD_APN_002”.

Ciao!
Tyrone