Problems bringing up iface with EM7565

I have an EM7565 module plugged into a M2-to-USB adapter. My linux host is running ModemManager and NetworkManager. I plug the module in, and all interfaces (/dev/USB[1-3] & /dev/cdc-wdm0) show up but the interface does not come up. Running mmcli --modem=0 shows me that the modem is registered,

 System   |               device: /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1
          |              drivers: qcserial, qmi_wwan
          |               plugin: Sierra
          |         primary port: cdc-wdm0
          |                ports: ttyUSB0 (qcdm), ttyUSB2 (at), cdc-wdm0 (qmi),
          |                       wwp0s20f0u1i8 (net)
 Numbers  |                  own: 17327793967
 Status   |                 lock: sim-pin2
          |       unlock retries: sim-pin (3), sim-pin2 (3), sim-puk (10), sim-puk2 (10)
          |                state: registered
          |          power state: on
          |          access tech: lte
          |       signal quality: 84% (recent)

so I run ifconfig wwp0s20f0u1i8 up but the flags seem to be incorrect…

els@elsm900-02:ifconfig wwp0s20f0u1i8
wwp0s20f0u1i8: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>  mtu 1500
        inet6 fe80::c661:1c10:e852:3a1e  prefixlen 64  scopeid 0x20<link>
        unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  txqueuelen 1000  (UNSPEC)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 10  bytes 480 (480.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Not sure why it comes up in POINTOPOINT. Typically the interface flags are more like <UP,BROADCAST,RUNNING,MULTICAST>. Ideally, I’d like it to show me the inet address for my interface. Any idea what I’m doing wrong?

Mmcli is using ppp dial up via AT command port
Have you tried qmicli

Thanks for replying, but what does that give me? I assume I need to reconfigure the modem (somehow) to not be in POINTOPOINT mode. Can I do that with qmicli?

you can see here about how to use qmicli to establish data connection

BTW, did you install the MBPL driver:

Yes, I did install the drivers. I was using this page as a reference:

but this line
sudo mmcli -m 0 --simple-connect=',ip-type=ipv4v6'
always fails with:
error: couldn't connect the modem: 'GDBus.Error:org.freedesktop.libqmi.Error.Protocol.CallFailed: QMI protocol error (14): 'CallFailed''
I will look at these other pages…

@jyijyi Thanks for replying. I’m now walking through the steps from Techship - FAQ - How to step by step set up a data connection over QMI interface using qmicli and in-kernel driver qmi_wwan in Linux?
I see a similar error when I execute

$: sudo qmicli --device=/dev/cdc-wdm0 --device-open-proxy --wds-start-network="ip-type=4," --client-no-release-cid
error: couldn't start network: QMI protocol error (14): 'CallFailed'
call end reason (1018): gsm-wcdma-option-unsubscribed
verbose call end reason (6,33): [3gpp] option-unsubscribed
[/dev/cdc-wdm0] Client ID not released:
        Service: 'wds'
            CID: '20'

Any thoughts?

Ok, I made progress. I believe I was using an incorrect apn. When I changed that commandline to use the apn that I had configured in the modem with AT+CGDCONT=1, then things got better! I’m not sure I understand what the APN actually is but one step at a time!