Problem with my rs232 serial port

I just came back after a few weeks away, and when I left all was well, now I cannot get my rs232 serial port to talk. I can communicate with the USB, but this is of course limited (no reprogramming). The day before I left I had tested a bit with an echo program that I found on the forum for the rs232 port, and this had worked well. I am sure this is no longer loaded because the modem is communicating with AirVantage now which is not included in the echo program.

With the USB port I have commanded ‘AT+WOPEN = 0’, verified it is 0 with ‘AT+WOPEN?’ and then powered off and on. I believe this should put the port back to its default settings! Any ideas on what the situation could be, and how I can check the RS232 configuration (Uart 1) and reconfigure it (from the USB port).


Any chance the uart port was disabled?

Could you please check AT+WMFM?


I am looking myself at the user’s manual, but this is what I got:


+WMFM: 0,2,1,1
+WMFM: 0,2,2,0
+WMFM: 0,2,3,1
+WMFM: 1,2,4,0
+WMFM: 1,2,4,1


Thanks for your help

I am looking at the program which I assume is running right now (problem with being gone for 3 weeks), and it is suppose to send a long string of data (it appears to be 150 or a bit more characters) at one time. It creates this with a sprintf, and then uses an adl_atSendResponse() to send it to the screen (which I never see) and then creates a message which it sends with this and sends it using the example’s (example for sending data to AirAdvantage) push_message() function. This had worked well with shorter data, and I changed the buffer size to be 500 bytes to avoid an overflow, but could this have caused an overflow internal to Open AT which now does not allow the serial port to function?

I would believe that any problem that this could have caused would be repaired with a reset with wopen = 0, but I need to ask. My problem is I do not know how to do much debug of this without the rs232.


I keep looking for something that will help with my problem and I have both stopped and eliminated the application now at+wopen=0, at+wopen=3 and at+wopen=4. However when I just restarted the application and decided to look again at the AT+WMFM? command, I see that I am still periodically getting:

+WDSI: 4

+WDSI: 8

+CREG: 1,“320F”,“0E06”

+CGREG: 1,“320F”,“0E06”

even though I confirmed that:




This does not seem normal to me!


Hi Don,

Thx, UART 1 port is enabled according to your +WMFM shared.
Any chance it is hardware or UART flow control problem causing no response on UART port?

By the way, +WDSI is indication for AirVantage service, once it is activated, it keeps running in FW regardless the OpenAT status.


I hope to open the box today (lacked the tools yesterday) and see if the cleaning crew could have caused it to fall or something, but as always after I left work I understood things better. I realized that I had misinterpreted certain things. I thought that when the application was not installed it would not continue to connect with the destination (AirAdvantage in this case) as it was not re-initialized by the application. Therefore I thought that I had the AirAdvantage code installed, when in reality, I probably had the echo software installed, and the RS232 configuration could have been left in Data Mode (and unfortunately I deleted this code which could have switched it back).

The first question therefore is: Would the RS232 return to AT mode on reboot if it was previously configured to Data mode, or would it remain in Data Mode?

second question is: If it would not return to AT mode, is there an AT command that I can use via the USB to return it to AT mode? I do not completely understand all of the descriptions of +WMFM.

third: If I cannot return to AT mode via the USB, can I return using the reset line?


I tried one other thing, I thought that I could possibly reprogram via AirVantage to solve the problem.
I started just by trying to upload some software we had previously used to talk to AirVantage, and failed on the installation with:

Conflicts in applications protocol [ac1cbe5d96f14e25a2bc187d5bbc9cbc]

Not sure what this means, but do you guys think that it would be possible to put some software in my modem via AirVantage. Someone said I need to make sure that SMS is enabled, which it is I believe:

+WIND: 32763

, anything else I need to do

Sorry for all of the effort, I found a mistake I had made, and I am back to communication with the modem (and I am more than a little embarrassed). Thanks for your help. How can I mark this as RESOLVED?

Just commenting here what was the tricky part/confusion might be sufficient Don (might be useful for somebody else in the future)
This forum is not intended to be an actual ticketing system so we don’t really change the status of the posts.


My tricky part seemed to only having left the configuration of the RS232 in something other than factory and which I forgot about during vacation. I actually had left the port in AT mode.

But my problems do not seem to be over:

For my project, I needed to set the interface to interface to 9600 with no hardware flow control. I understand the two commands to get back to factory settings are:


I change these within RealTerm (as the interface using Developer Studio tries to do too much)

Afterwards I encounter two problems:

  1. I can open the port and send commands, but when I try to download a program I get through all of the block loads and then receive a timeout with the following details:

Download file AirVantage.dwl to port COM8, reload informations and check => ERROR: Time out: 20000ms
Download file AirVantage.dwl to port COM8, reload informations and check => ERROR: Time out: 20000ms
Open port COM8 => DONE: Success
Open port COM8 => NO NEED TO DO IT: Success
Waiting for module detection => DONE: Target detected sn:BH3220191308101 baudrate:115200
Switch to Development mode and check => DONE: Success
Switch to Development mode => DONE: Success
Pause : 300 milliseconds => DONE: Success
Check dev mode unlocked => DONE: Success
Enable persistent development mode => DONE: Success
Show a CONFIRM dialog with message => NO NEED TO DO IT: Success
DWL File parsing => DONE: Success
Show a CONFIRM dialog with message => NO NEED TO DO IT: Success
Load model element: Target Informations => DONE: Target Informations received: [dwlBean=size=55344, buildDate=111611 18:03, version=V08b13, checksum=-576493737, startAddress=65536, fwBean=size=2223904, buildDate=121712 09:52, version=R7.47.6.201212170952, checksum=-1252995348, startAddress=131072, modemBean=, appBean=size=899052, buildDate=082813 16:41, version=, checksum=-1246819435, startAddress=2490368 components={Open AT Application Framework package=, Developer Studio=, Internet Library Package=, AirVantage Agent Library Package=5.3.0.I201306171916, Firmware Package=, Open AT OS Package=}, name=AVSampleDemo Sample, companyName=Datus, , totalRAMSize=2097152, totalFlashSize=8388608, maxOatAppFlashSize=4194304, maxADFlashSize=786432, appStarted=false, localPortID=1, FXT009, com.wavecom.spm.model.wpkg.impl.FirmwareImpl@63db699d (persistedModelVersion: 1.0.0, relativePath: d:/Program Files/Sierra Wireless/Embedded Software/com.wavecom.openat.ide.spm.fw.model., mainTocReference: …/com.wavecom.spm.model/tocFW.xml#openAtFwDoc, pluginPathOffset: resources, externalPath: null, resourcesHash: 94212630960985) (appFlows: [ADL, LLH, HLH], heapOverheadSize: 16), false, 1000]
Check pre-condition before download => DONE: Success
Check if target WCPUID is compatible with application => DONE: Target WCPUID is compatible with application
Check if the Open AT area size is enough => DONE: Success
Check application overwrites the current flash mapping => DONE: No flash mapping
Check total flash size of the Open AT application => DONE: Success
Check memory size => DONE: Success
Check if the file already has been downloaded on target => DONE: File is different from the target one.
Check start addresses => DONE: Success
Copy DWL file AirVantage.dwl to temporary path => DONE: Success
Download file AirVantage.dwl to port COM8 => DONE: Success
Load informations from target => ERROR: Time out: 20000ms
Waiting for module detection => ERROR: Time out: 20000ms

  1. When I close the port in Developer studio, I return to 9600 baud although the hardware control
    AT+IFC=2,2 seems to stay in place.

I should note that I tried to do things step by step with first working with only changing the rate, and I even received errors when trying to open the port in Developer studio.

OK back again,

The error in the programming seems to occur because the rate gets set back to 9600 after the load and so when Developer Studio goes to do verifications, it does not receive any response to its commands which are sent at 9600. By ignoring this, I uploaded a program which changed the baud rate using the create commands from within the ADL function specifying Uart1 (Same command that got me in trouble in the first place except now with the default baud rate!).

I could then, by returning to 9600 baud, start the program and the baud rate changed and seems to be staying changed.