Problem with flashing EM7565 via MBPL R27

Hi, I am trying to flash the latest generic firmware on an EM7565 using MBPL_SDK_R27_ENG4-fwdwl.
However the process got stuck at downloading the cwe file for more than 30 minutes with no signs of progress. I put both cwe and nvu files in the same folder and I tried the basic command. See below

sudo SampleApps/lite-fw-download/bin/fwdwl-litehostx86_64 -f fw
Application version: 1.0.2204.2
INFO: QDL Port :
INFO: Device Path: /dev/cdc-wdm0
INFO: FW Path : fw
Target image Info:
Carrier :GENERIC
FW Version :
Model ID :SWI9X50C
Package ID :000
PRI Version:002.048
SKU :9999999
Switching device into download mode …
Modem Needs FW
Modem Needs PRI
Waiting for modem to disconnect from the host …
Modem disconnected from host.
Waiting for modem to come up in BOOT and HOLD mode …
QDL port found: /dev/ttyUSB0
BOOT and HOLD Mode. Downloading firmware …
Downloading: fw/SWI9X50C_01.14.13.00.cwe

After waiting for what I thought was long enough (didn’t check but more than 30 minutes) I ctrl-c the process. Now I think the device is stuck in QDL mode and does not create the /dev/cdc-wdm0 device anymore

A few questions:
how can I reset the device in normal mode to try again?
what is a safe procedure to flash the em7565?


here says it should be OK:

That is what I did, but it didn’t work for me. Unfortunately.
Flashing through windows worked though.