Problem with changing handshaking - old position "Overv

I have another problem concerning handshaking during communication beetween modem and PC.
In the following code I have done a little change in HelloWord application.
I would continually sending “Hello world” but at a baud rate of 19200 bps, parity even and no handshake.



void adl_main ( adl_InitType_e InitType )
    TRACE (( 1, "Embedded Application : Main" ));
//uart1 closing
   adl_atCmdCreate("AT+WMFM=0,0,1",ADL_AT_PORT_TYPE( ADL_AT_UART1, FALSE ),(adl_atRspHandler_t)ATD_Response_Handler,"*",NULL);

//baud rate
adl_atCmdCreate("at+ipr=19200",ADL_AT_PORT_TYPE( ADL_AT_UART1, FALSE ),(adl_atRspHandler_t)ATD_Response_Handler,"*",NULL);

adl_atCmdCreate("at+icf=2,1",ADL_AT_PORT_TYPE( ADL_AT_UART1, FALSE ),(adl_atRspHandler_t)ATD_Response_Handler,"*",NULL);

adl_atCmdCreate("at+ifc=0,0",ADL_AT_PORT_TYPE( ADL_AT_UART1, FALSE ),(adl_atRspHandler_t)ATD_Response_Handler,"*",NULL);

//uart1 opening
   adl_atCmdCreate("AT+WMFM=0,1,1",ADL_AT_PORT_TYPE( ADL_AT_UART1, FALSE ),(adl_atRspHandler_t)ATD_Response_Handler,"*",NULL);

   // Set 1s cyclic timer
    adl_tmrSubscribe ( TRUE, 30, ADL_TMR_TYPE_100MS, HelloWorld_TimerHandler );

There’s no problem with baud rate and parity but the modem doesn’t respond anymore when I change the handshake setting.

You have any ideas?


Duplicate Post: … php?p=3485

Excuse me very much for the waste of space on the forum but I think that problem about handshake concern “Flow Control Manager” instead “Overview”.