Problem during GPRS connection


#1

Hi to all!!. I made a GPRS/GSM application thanks to your help, so once more im really thanksfull to all of you.

Now, my aplicattion is ready and function, sendig small packets to a server and recieving small responses from it and it works just fine for the first 45 minutes, then it just freezes. The CPU dont send any traces to the M2M so i dont know whats happening but response tho the AT commands that i send in the Shell. There is some kind of watchdog timer or something that is blocking my CPU??. Please note that i`ve tried this twice with different packet sizes but it takes the same time to freeze!.

Once more time, thanks.


#2

Just to clarify: are you saying that Traces are working initially, then they stop (after ~45 mins) - but the unit continues to respond to AT commands?


#3

Exactly, the last trace shows the packet recieved from the CPU. Note that this one is inside the READ case from the TCP IP handler.


#4

OK, so the fact that AT commands still work show that the whole unit is not dead.

My first step would be to set up a custom AT command that will just give a message in the Trace - so that you can see if the Trace is still working, or if M2MStudio has somehow lost contact with the unit.

Once you’re sure that the Trace is still working, you can add traces to your application to attempt to pin-down where it stops…


#5

ill do that. Im trying it right now, i use a timer just to restart the connection 40 min after it starts, i want to see what happends. Then ill try your idea. Im sure ill come with some news. Thanks again!!.


#6

Hi again!!, sorry for the delay!. It happend something really strange, i let the CPU working all weekend and it works just fine!. I guess that its a ground problem, because im using the test Board and the cpu its not weld properly.

Thank u all!!.


#7

Doesn’t quite seem to fit the observed symptoms - that it worked for ~45min, but then stopped.

But then “ground problems” can cause very weird effects…! :confused:

Yes, that does seem to be a common cause of many problems!