Power cosumption mode in Q2686 module and problem


#1

Hello all,

I am using Q2686 module with external controller. To send Q2686 gsm module to power down mode ( because my basic aim is to save power as device is battery operated and at remote location) I am sending AT+CPOF command from controller to wavecom module. Now to wakeup GSM module I am sending AT+CFUN=1 command from controller and after that I am making a data call using ATD command. The problem here is that I am getting no carrier signal after making a data call. So why I am getting such response from modem. Whether I am doing something wrong.
Because normally when I am initiating a data call it works fine. Or please specify the correct procedure to bring the Q2686 gsm module into sleep mode back into wakeup or normal mode.

Your reply will be helpful to me.

Thaking you


#2

Are you waiting long enough for the module to re-register to the network?


#3

Hello,

Thanks for your reply.

After sending AT+CFUN=1 command I am waiting for 2 sec and then dials data number but I am getting no carrier response.


#4

I think it is highly likely that the unit will not have re-registered in that time.

Anyhow, you should not rely on a “blind” time delay - far better to specifically check for registration; eg, by enabling +CREG unsolicited responses…


#5

Hello,

I enabled the unsolicited +CREG response but again problem is that after AT+CFUN=1 I am not getting the modem response
on the UART1 which is connected to other controller. Actually I am using numerical modem responces to control the data call. Can this be a problem. please suggest something.

Thanks and Regards


#6

Read the AT Commands Manual carefully: the +CREG setting is not saved automatically…

No.


#7

Hi,

I enabling the +CREG responses I am using AT&W command to save it before AT+CPOF.


#8

Then you should get +CREG responses when the unit starts searching for the network, and when it registers.

If you’re not getting those results, then the unit is not searching for the network, nor registering - which would obviously mean that you can’t make calls!


#9

Hello all,

I tried the AT+CPOF command to set the device in power down mode.
But even though I am getting OK response after AT+CPOF the current consumption is same as when the device is active.
What something else needs to do to save the power. Because my device is battery operated and GSM is taking near about 240mA current when it is active. I tried the AT+CPOF command but it is taking the same current.

Please suggest any solution to bring down the current consumption to few microamp.

Thanks and Regards


#10

There is an appendix at the end of the AT Commands Manual that describes the “Working Modes”- ie, the different power-consumption modes.

There is also an application note.

It’s all quite involved and not terribly clear - you would certainly be best to sit down with your distributor and discuss this face-to-face with plenty of paper in front of you…


#11

Hi Yogesh,

I am working on something similar. I use AT+W32K=1,0 to bring down mA, but you need 7.3 firmware to be able to use that command.

Also mind that if you are using the board you need to disconnect the serial to bring consumption down (otherwise it will stay up no matter the mode). Give it a try. There is also an AT+WBHV command I guess but I haven’t tried it.

According to Wavecom doc +CREG should be up by themselves becuase it one of the settings the OS wants to run (after AT+WOPEN=1).

Briga


#12

To reduce power consumption wavecom modules have ON/~OFF pin. If this pin is set to HIGH than issuing AT+CPOF command just switches off GSM part of module. This mode does not save much power cause GSM is designed to consume as low power as possible. But if you set this pin to LOW than your module will be entierly switched off after AT+CPOF. I think it is the lowest consumption mode ever.


#13

Briga, what consumption did you achieve wit AT+W32K=1?


#14

Hi blackyblack,

You are right, now I am using ON/~OFF pin and CPOF command to send gsm into power down mode.
To send gsm into power down ON/~OFF pin must be low and then issue AT+CPOF command will send gsm into power down
mode and module then takes only few microamp current.
To wakeup the the gsm module, ON/~OFF pin must be high and wait for module to register.

Regards


#15

You don’t need to wait that long - but it won’t hurt if you do.


#16

Hello all,
in my OpenAT application, I use ‘at+w32k=1’ command to force the Q2686 to go to low power. The low power works very well, but the big problem is that sometimes, out of control, the module resets! Reading the traces the cause is ‘watchdog reset, tsk:0’. Also, the same application without the low power function does not reset. I tried to find something about the watchdog in Q2686 in order to switch it off, but the information on the documentations is not enough.
Please, could someone help me ??
Tanks

Massy