No communication with BC127 Development board

I’m not able to communicate in the CMD mode with just purchased BC127 Development Kit.
I’m using CoolTerm. I get an error message “ERROR 100” I’ve also got an “error 0x003” when trying to use the Arduino serial port monitor.
I wish to change the settings so it is a source device and will communicate via HFP and HSP to a bluetooth earbud in sink mode.
I think I am to use the USB UART connector.
I’ve tried using Mac OS High Sierra and Windows 10 with CoolTerm. Got closer with the Mac. I’m really new to the Bluetooth world. I looked at the port permissions. They are wide open at chmod 666. I seem stuck as to what is going on. Using 9600-8-1 CR only.

Partially solved problem. There are 3 different usb connections the board outputs. the usb spp1 and usb spp2 ports to not work. I had to use usbserial xxxxx. Poor documentation…


Not sure what ‘documentation’ you are looking at but the discovery user guide is pretty clear about howto use it.



Hi Mike,
Thanks for answering. I did have the documentation you suggested. I just did a search on the document you sent. There are two references to SPP neither one goes into any detail. It just says when you connect to SPP. As a newbie, that’s not enough detail to show me how to connect to get into the command mode. Especially when I connected to SPP and did not know enough that that was the wrong connection to use. I think the document was written for people with tribal knowledge and could be improved.