New SW modules seize up and stop responding when sending SMS

The new 3G modules (or the serial interface) have the tendency to hang when using AT command to send SMS over serial.

I’ve been having to live with this problem since FX100 and now M100 3G that uses the SL80XXS. Increasing the interval between characters in the serial stream will helps to greatly reduce the likelihood of this happening but is not full proof and every 1000-10000 SMS sent will result in the module seizing up and stop responding to any AT command including AT+CFUN=1. Tried both HW and SW flow control.

This bug didn’t exist for earlier Wavecom modems like Supreme 20 which is ultra stable, you can throw anything at it, disconnect the serial port, it wouldn’t hang.

Is there a solution for this or is this a hardware defect in the newer modules? This bug has been around for years. I’ve tried upgrading to firmware R7.54, still no help. Thanks in advance. :smiley:

Can you please confirm that the issue is in Sierra wireless module and not in M100 3G module . If you found issue with sierra wireless module then this problem needs a detailed technical analysis. Please contact your Technical support in SWI to provide you the solution.

Thanks & Regards,

It’s a M100 3G terminal using a SL8082TR module. I’ve been having this problem since like 2 years ago with different terminals and have been hoping that the problem will go away with newer Firmware but it didn’t happen. Here’s what I got from Hypterminal.

Note: The firmware was originally r7.52.2.a5.201411281219.sl8082tr 1804452 112814 12:19.

SL8082TR Product

R7.54.0.A1.201603171313.SL8082TR 1997208 031716 13:13


Sierra Wireless

SL8082TR Product

"DWL"," C04.05.14.00.SL8RDBT R2684 CNSHZ-ED-XP0031 2015/11/05 21:36:55","","Sier
ra Wireless",0,"","00000000","00000000"
"FW","FW_754_0_A1_22_1.SL808FAx","R7.54.0.A1.201603171313.SL8082TR","Sierra Wire
less",1997208,"031716 13:13","a887779d","10002020"
"MODEM 3G+","Revision: C04.05.14.00.SL8RDAP R2684 CNSHZ-ED-XP0031 2015/11/05 21: