Need Help Configuring IP

Hi, I’m quite new to Legato and have a ‘‘Airprime Development Kit’’ with a AR7/WP7 module. I’ve tried the steps given to configure the IP but I am unable to do so. I get the inet6 addr. but do not get the inet addr. Tried both Ethernet as well as USB. Anybody got a solution for this ??

Does this getstarted info help?

If you are using ethernet, it should get IP address from your router/dhcp server automatically.
If you are using USB, please follow the steps and remember to setup the IP address on your host PC too.

Hope it helps.

Gone through this step by step and still no success.

Steps i am following…

Removing my system from LAN and connecting the kit in LAN. (or both of them should be in LAN simultaneously ??)

my Host IP is configured. when connected in LAN i am getting 2 IP’s (inet addresses): eth0 and lo
i am disconnecting the kit from LAN and only then going for USB.

please guide if i am doing something incorrectly.


You can always configure an inet addr by running ‘ifconfig eth0 up’ on target.


I was trying to assign a static ip to it and got success in that… Thanx anyways :slight_smile: