Modem MC8790V doesn't work


#1

Hello
my modem show me Functionality minimum
and when I try to tell him :
AT!ENTERCND=“A710”
At+cfun=1
at!greset

it doesn’t help
also it doesn’t save me the at+cfun=1 , it’s return to at+cfun=0

why is it , and how do I make it work?
I have something like ~50 units and is the same in all of them


#2

Maybe you can query “AT!PCINFO?”, from there it will show the actual power control status.

Kindly refer to Extended AT command guide for details.

Thx


#3

OK
at!pcinfo?
State: 0 (LPM)
LPM force flags - W_DISABLE:0, User:0, Temp:1, Volt:1
W_DISABLE: 0
Poweroff mode: 2
LPM Persistent: 0

OK

now what? How do I change the State to 2 (make the modem online?)

Thanks ,


#4

Hi David,

From the response,

so the cause of low power mode is the temperature and voltage is outside the operational limits.

You can further check AT!PCVOLT? and AT!PCTEMP? to find the current temperature and voltage level detected by module and the state.

Please refer to PTS and use AT!PCVOLTLIMITS? and AT!PCTEMPLIMITS? to check the voltage/temperature requirement and see if normal operational environment can be achieved.

In worst case, if the environmental behavior cannot be changed, you may modify the setting via these two commands but use with patient as which may damage the module, please refer to Extended AT command guide or contact your FAE/distributor for info.

Thx


#5

I assume that the problem is in the Volt ,but I didn’t find this command - Thanks.

this is what I get :

how is it possible ? this is normal mini-pci-express that should bring me 3.4V no?

I have looked at the datasheet of the MC8790V - it can’t work in 5V ,is he?


#6

problem solve
the card I’m using with the modem has change , this is why it didn’t work.
the even didn’t know this is a problem - but now they do.

Thanks for all the help ,