Modem Hangs

UPDATE: The problem described below seems to be a different scenario from the original thread and has been reposted as a new thread

I have an issue with the Wavecom Supreme that sounds very similar to the problem reported here. We have modems crashing at random intervals between 15 minutes and 40 minutes. In most cases the modems will recover and continue service, but every once in a while, it will stop responding completely. Recycling the power to the modem always solves the issue. These modems are quite busy and may send/receive up to a thousand SMSes per hour.

Some background info: We have 4 Wavecom Fastrack Supreme 20 modems connected to a single server. Two modems are used for sending SMS’es and two modems for receiving SMS’es. The receiving modems are polled constantly (user definable interval) while the sending modems are only communicated with about once a minute. The crashes are always on the receiving modems. We are using the USB connection (expansion card), but serial (RS232) seems to have the same issue. (Unfortunately, the problem manifests in a different way with RS232, so this is not conclusive).

We have extensive logs of all transactions to the modem, so I am able to give you a pretty clear picture of what is happening.

  1. The problem happens during times of high SMS traffic (sending as well as receiving)
  2. Windows will report to our software that the USB connection has failed.
    2a) First, a USB request will fail after a random period with “I/O operation has been aborted…”
    2b) Next, all subsequent requests will return immediately with “Device attached to the system is not functioning”
  3. Most of the time, the failure only persists for (a random period) of a few seconds.
  4. Once in a while, it will fail to recover and only a power cycle will bring it back again.
  5. Sometimes, it will fail again a second or two later. This has happened as much as 5 times in a row.
  6. Time between failures are random, but it seems no shorter than about 13 minutes and at least once an hour.
  7. The problem is very repeatable and failure always happens with the same error codes.

It is clear that the USB connection fails, which indicates that the modem CPU is resetting. It will also seem that these (auto) resets are not always complete (or successful), because we have observed a number of times that the modem responded again after a soft reset, but it fails to connect to the GSM network. Again, a hard power cycle will solve this.

Things that we tried (with no success):

  1. Swapped modems around and even got two new modems
  2. Tried different (higher quality) USB cables
  3. Tried a combination of USB ports on the motherboard and on a USB addon card
  4. Added a whasher to the antenna connector to improve the ground reference (Wavecom document ref: WA_DEV_Fastrk_CRN_002)
  5. Moved antennas further apart and as far as possible away from the USB cables

We are pretty confident that the issue is not with our software as the software had been in use for more than 7 years.

Modem info is:
at+whwv => Hardware Version 4.22
at+cgmr => R71a01gg.FSU005 2076692 052808 20:08

Hi,

I discovered my problem’s cause. That was about the operator servise or bad signal quality. my modem’s led doesnt blink anymore (always shines) when this problem occurs. The software inside the modem still works even if it losts the operator service . To solve this problem, i set a timer with 30 minutes period, and check the AT+CREG? response. I realised that i get this problem when AT+CREG returns +CREG: 0,2 (means no operator found).

I think this is not similiar with your problem. But it may help others. I restart modem if i get +CREG: 0,2 and trying to connect again.

Thanks for the response. I think I will repost my comment to a new thread to avoid confusion.