MC8705 - Enabling SUPL?

I am evaluating this as a replacement for our MC8790 units on which we developed an embedded system. I have gpsOne and SUPL and NTP servers working on the 8790 units fine.

I can use the AT!GPSSUPLURL command to set the server per the advanced AT settings document, but when I try to use the AT!GPSPORTID command to set the TCP/IP port so that it can communicate, I get the following error:


The documentation does not show any way to set the port and the modem is not working in MS-Based mode, as it cannot get the information from the server. I have tried various variations on the AT!GPSSUPLURL value to try to see if it takes a port at the end like a web url or the like with no success.

Edit: I should add that it doesn’t even fall back to standalone mode, it just fails to do a fix at all when in this mode. If I then set it back to standalone mode for the fixes instead, it works “normally”. I would have expected the unit to use these enhanced features where possible, but fall back if they don’t work. Apparently it is up to the application to change modes instead.

Here is the output of my ATi5:

Manufacturer: Sierra Wireless, Incorporated
Model: MC8705
Revision: T1_0_1_1AP R309 CNSZXL00000015 2011/01/21 18:28:30
IMEI: <Removed for security>
FSN: <Removed for security>
3GPP Release 7

I have sent an email trying to get a contact to see if there is a newer firmware since I cannot seem to locate one on the developer site. Thanks in advance for any information that you can provide to get this working and move the testing along!

Now I am really confused.

Per the 2130616 PDF document [AirPrime MC/SL-Series (UMTS/LTE) Extended AT Command Reference, Rev 8 May 12, 2012], in July of 2008, they deprecated the GPSPORTID command. However, in March 2010, they updated the description of that command, and in November 2010, they updated the description again.

Further, on page 22 of rev 8 of the document, they have it in a table of valid commands. In the GPSIPADDR command, it indicates that the GPSIPADDR command is deprecated and the GPSSUPLURL command should be used, but to see also the GPSPORTID command.

The section for the GPSPORTID command makes no reference to it being deprecated whatsoever and also refers to the GPSSUPLURL command.

The GPSSUPLURL section clearly states you MUST use the GPSPORTID command to set the port.

Am I barking up the wrong tree in trying to get this to work, especially since it worked on our older MC8790 series (but with more recent firmware)? We need fast fixes, as some of our customers are emergency services.

After fighting not being able to log in to the forum again to update, I am able to update this thread.

I was contacted by support and we worked out the issue.

You do not need the GPSPORTID command with the GPSSUPLURL, only with the GPSIPADDR command, the docs are a bit misleading. As a result, it is deprecated along with the GPSIPADDR command.

My gpsOne extra and SUPL appear to be working. I had to enter the GPSSUPLURL and then enable it when I set my GPSAUTOSTART parameters.

Perhaps the new firmware provided helped the issue as well.

Thanks for the great support from Sierra and my vendor working together.

Hi pdbuick,Sorry to revive an old thread but I am trying to get the Assisted GPS to work on the MC8705 and having no luck.

I sometimes am in a weak GPS spot and would like to use the assisted GPS to give a lock quickly.

I first try to use the 1Xtra to help with the FIX and download the data
Xtra Time status = Unknown
Xtra Data status = Valid
Validity Start = 2013 11 17 6 21:00:00
Validity End = 2013 11 24 6 21:00:00

It seems to make no difference in the AT!GPSFIX=1,15,10 request. In a poor GPS reception area I still get regular failures.

So I have been trying to get the Assisted GPS to work… modes 2 and 3 for the FIX request.

I have ensured that the SUPL URL is set. I have tried both tmobile and google’s supl servers.

It seems as though they aren’t used at all. I have ensured that all the positioning modes are enabled ;

MASK: 0x0000007F

So the next question is how do I get
2=MS-based only
3=MS-assisted only
Modes working for the FIX request ?

What am I missing ?

My modem software is:
T3_5_2_1AP R517 CNSZXD00000128 2012/02/07 13:03:25

Hope you can help.


Per this url:, Standalone mode doesn’t use the carrier for anything.

MS-Based uses the SUPL data and time etc. to allow the GPS to make better decisions as to which satellites to use and may get some assistance in calculating the position.

MS-Assisted uses the service providers’ servers entirely to do the fix based on the GPS sending some fragments of GPS data.

It seems that in all three cases, the GPS unit has to be able to receive some data from the satellites, whether to use it itself or to send it to the server to get assistance.

I honestly hadn’t kept at it to get it working, as we are still using the older modems that we have in stock and haven’t moved forward with the MC8705. I assumed our carrier didn’t provide the support for it, but as I say, that’s an assumption as I hadn’t pursued it. Perhaps someone else can shed some further light?

Thanks for the update, I now have a ticket open with an FAE for Sierra.

He can’t get it working either so is now working with their head office in Paris to get it to work.

Like yourself our device will be used in Emergency Services Vehicles so needs to have a fast reliable GPS reading.

If / when I get it working I will post a solution :smiley: