GPS, MS-based and MS-assisted mode in MC8705


I am trying to gather GPS information from MC8705 modem, and seems the standalone mode works perfectly.
But when I try MS-based and MS-assisted modes, modem is not able to get any information from A-GPS server - modem always reports Error code = 15. My SIM has data plan and works well with Rogers network.

Current time: 2013 07 25 3 22:04:37

2013 07 25 3 22:04:34 Last Fix Status = FAIL, FAILCODE = 15
2013 07 25 3 22:04:34 Fix Session Status = FAIL, FAILCODE = 15

No TTFF available


Do I miss any configuration ?


According Table 9.3 of Extended AT command, Error code 15 is “Error in fix” ? What the explanation is !


Did u tried setting the configuration using !GPSPOSMODE command.


Hi Rex,

Yes , I did try that command and still doesn’t work.
Even I used Aircard watcher and Sierra wireless development board, I got the same error.

Any new news on this problem? Having similar issues. :slight_smile:


I stop working on this issue since the wireless carrier in my region doesn’t support GPS server. I think we might need to have GPS service from carrier - not pretty sure.

Other than the ephemeris data and date/time from SUPL, yes, my research has shown that the carrier has to provide servers to provide this service and they seem to have been rolling it out starting with major population centres.

I found some information at