MC7750 on a CF-31 Toughbook - Desperate for help


#1

Hello, My name is Mike. Please bear with me i am new at this and desperately need assistance. I have a CF-31 Toughbook with an MC7750 Verizon aircard. Up until a few days ago I cannot get this thing to connect to 4G anymore. I am also using Aircard Watcher as opposed to VZW Manager.

I have uninstalled and reinstalled drivers, reinstalled AirCard Watcher, even installed the VZW manager from the panasonic site and the one on the Verizon website. I have other devices that are all connected to Verizon 4G and spoke with Verizon already. I know its not a network issue. It was working perfectly fine with AirCard watcher. Even downloading the VZW Software still shows a 3G connection.

My County 911 center installed a NetMotion VPN Client and Public Safety software. It was even working fine with that. I turned off the VPN, killed services, etc still no changes. I even did a system restore and went back a few days prior to those software installations. Even removed the card after uninstalling all drivers and software and starting over… Still no difference. Stuck at 3G speeds.

I have read in quite a few posts that this card has a lot of issues when it comes to 4G. I even read on one post that its a known issue that if the signal drops to 3G it cannot reconnect to 4G for some reason. I hope there is someone out there that can help that has seen this issue in the past

Current Firmware is: 03.05.10.13
Current Driver package: 13.4.1050.41 (downloaded from Panasonic)
OS: Win 7 64 Bit
APN: VZWINTERNET


#2

I have this this issue myself on numerous toughbooks, but have not found a solution. It like these cards just get stuck in 3g and show 4g unavailable. Any help from sierra forum would be much appreciated!


#3

did any one help you? I have having a problem like you. I am using the MP70 trying to connect a CF-30.


#4

Did you ever find a solution to the 3G issue?


#5

Hi Mike,

Sorry to hear that you have issues with MC7750. Have you tried to engage Panasonic to find out what might have gone wrong? What do you get from the following AT commands response?
AT!GSTATUS?
AT+CGDCONT?
AT!SELRAT?