MC7700(AT&T) QMI, Call Failed


I am using module MC7700(for AT&T) in our router. We have to use firmware version SWI9200X_03.05.20.03ap because of PTCRB. When I am trying to connect to network by QMI_WDS_START_NETWORK_INTERFACE(0x0020) I got error “Call Failed(14)” and error codes 12, 204. When I was using the firmware SWI9200X_03.00.05.04AP I did not have this problem. I found, when I switch module by AT!SELRAT to UMTS/HSPA, module will connect to 3G network without problems. When I switch module back to automatic selection(AT!SELRAT=0), module will connect to LTE network and is working well from this time. Have you ever seen this behavior?

Thanks for answers.


ohh strange…

have not seen this behavior…

Did u see any long gap after you have sent the QMI message before that error came?
also, in the FW SWI9200X_03.05.20.03ap, did everything worked fine when u do !selrat settings?

Not sure, but may be u need to set selrat… need to check this…

I think this QMI message maps to SLQSStartStopDataSession API… can you try to use Linux SDK and see whether the same issue is coming or not… just to verify…


in the attachement you can see log file from our device.

Did u see any long gap after you have sent the QMI message before that error came?
Yes, it take about 10s between request and error.

2014-04-29 00:01:23 usbd[1000]: usbd started
2014-04-29 00:01:23 usbd[1000]: establishing connection
2014-04-29 00:01:23 usbd[1000]: sent [00 01 00 20 00 16 00 14 09 00 62 72 6F 61 64 62 61 6E 64 16 01 00 03 17 00 00 18 00 00]
2014-04-29 00:01:33 usbd[1000]: rcvd [02 01 00 20 00 13 00 02 04 00 01 00 0E 00 10 02 00 0C 00 11 04 00 02 00 CC 00]
2014-04-29 00:01:33 usbd[1000]: result is 14
2014-04-29 00:01:33 usbd[1000]: connection error: code 12,204

We use AT!SELRAT=0 in default, but factory fresh module not work with this settings. When I set SELRAT to UMTS/HSPA(I do not remember the number), router will connect to 3G network. When I set SELRAT back to 0, router is able to connect to LTE without problems. Module is working forever from this time.

I found similar behaviour when I use command AT!SCLTEPROF:

Default value is 1 and module is not able to connect to network. When I set SCLTEPROF to 2, module will connect to newtork. After that I can set SCLTEPROF back to 1 and module is still able to connect…

In the log file you can see whole sequece of AT & QMI commands we use. Maybe you will see what is missing or bad.
SPECTRE-LTE.log (6.7 KB)

Does it help to attach manually to the LTE network first, using QMI_NAS_INITIATE_ATTACH?


I have just tried it, but I got result code 0x1A - QMI_ERR_NO_EFFECT(Does not matter if I use attach or detach)


I found solution of my problem. When I set APN and authentication type in “AT&T Mobile” profile(by QMI_WDS_MODIFY_PROFILE_SETTINGS), module is able to connect to network. I do not understand why is neccessary to do that, because in the QMI_WDS_START_NETWORK_INTERFACE message I am giving the same values to module. But without modifing the profile module is not able to connect.