MC7455 USB interface for PPP connection


Does anybody know how to use MC7455 module to connect via PPP. What USB interface should be used for this purpose? The problem is that I have an old system which works fine with MC7710 (running with UDUSBCOMP=3) and connects via PPP successfully.
Now I would like to replace MC7710 by new MC7455 modules and connect to network via PPP again.

Any ideas or recommendations will be appreciated!
With Regards,

You can use AT command port.

Thank you jyijyi!
The point is that MC77xx has a second port which we were using for data session (usb interface #4) and AT port using for monitoring RSSI, coverage after connection established. Is there a such interface for MC7455 to use for data session?

With Regards,

You can check which port can be enabled by

If there is only one AT port, you can try to use CMUX.


What “at!isbcomp=?” suggests are the following:

- configuration index to which the composition applies, should be 1

- 1:Generic, 2:USBIF-MBIM, 3:RNDIS
config type 2/3 should only be used for specific Sierra PIDs: 68B1, 9068
customized VID/PID should use config type 1

- DIAG - 0x00000001,
NMEA - 0x00000004,
MODEM - 0x00000008,
RMNET0 - 0x00000100,
RMNET1 - 0x00000400,
MBIM - 0x00001000,
10D - diag, nmea, modem, rmnet interfaces enabled
1009 - diag, modem, mbim interfaces enabled

The default configuration is:


Can I use any of RMNET interfaces for this purpose or the CMUX is the only choice for me?
WIth Regards,

Seems only one AT port can be used.

you can use rmnet where you can use qmi sdk to get the rssi.

Thank you!
About CMUX: how can I activate CMUX on AT port?

Please see the +cmux command in user guide

I have already read command reference. It says +CMUX is supported when MUX
mode configured on USB interface. So, my question is how to enable/configure on USB interface? Should I use !USBCOMP command to do it or it is something that should be done on the system?

With Regards,

I think you can directly try on usb AT port first.

Dear jyijyi,

Thank you for recommendation! The point is that AT+CNUM command returns ERROR. The command reference document of MC7455 states that +CNUM command is supported only when the MUX mode is enabled on USB interface. Should the system be changed to enable MUX mode or it should be done by another AT command?

Just have a try here, you are right, the mux command cannot be entered.
Then probably you need to use QMI SDK to get the RSSI.

Ok jyijyi, thank you very much!

Hi jyijyi,

During my investigations to find out the right usbcomp of MC7455 for me I eventually lost my AT command port after changing the USBPID to 9068 and setting usbcomp=1,3,50D. So, now my MC7455 module runs in RNDIS mode and there is no AT port to switch back to Generic mode (usbcomp=1,1,50D). Is there a method to reset the settings to factory default? I have an evaluation board to connect MC7455 to PC.

With Regards,

what port did you see in linux platform?
Not sure if you can use /dev/cdc-wdm port and switch back like this link:


Hopefully I don’t throw a spanner in the works but you can use the RMNet interface using ~AT commands just as you were able to use DirectIP with the MC7710. To do this have a read of this document 1aec569af75a1ab07c66bf85086071fc482f614b.docx (347.1 KB) a lot of ourEM/MC74 customer use the unit this way, you do really need to use the GobiSerial and Net drivers.

PPP was deprecated by Qualcomm quite sometime ago although it still works, it is not really recommended because there are a lot of limitations (not least the deprecated bit).



Thank you! It was very useful information! I will give it a try.

Hi jyijyi,

I connected MC7455 (with lost AT command port, it is in RNDIS mode) to my PC (running Ubuntu 18.04) and found out the following in dmesg:

[ 8455.619141] usb 1-1: new high-speed USB device number 10 using xhci_hcd
[ 8455.769743] usb 1-1: New USB device found, idVendor=1199, idProduct=9068
[ 8455.769748] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 8455.769752] usb 1-1: Product: MC7455
[ 8455.769755] usb 1-1: Manufacturer: Sierra Wireless, Incorporated
[ 8455.769758] usb 1-1: SerialNumber: LQ82639012011025
[ 8455.775049] rndis_host 1-1:1.0 usb0: register ‘rndis_host’ at usb-0000:00:14.0-1, RNDIS device, aa:e7:96:36:f3:b1
[ 8455.793267] rndis_host 1-1:1.0 enp0s20f0u1: renamed from usb0
[ 8455.822862] IPv6: ADDRCONF(NETDEV_UP): enp0s20f0u1: link is not ready

Is there a chance to change it to generic mode?

You might try to use what mlw recommemded so that you can send AT command to change it back to generic

Dear jyijyi,

mlw’s recommendation is related to using RMNET interface as other wired network interface after module is connected to network using AT commands. I hope this will be useful for us. I will give it a try.
Before that I need to restore my usbcomp to Generic mode. It is now in RNDIS mode and I lost AT port. My questions is: is there a way to change back the USBCOMP to generic mode if my module is in RNDIS mode?