[MC7455] Stuck in MBIM-mode


#1

I recently switch the modem in MBIM using AT!USBPID=68B1. Apparently the modem is not responding to commands and the serial for the AT commands is no longer exposed. Is there any way I can get the modem back?


#2

We have in the past produced one click updaters to change the settings to recover units but I do not know of one to do it on the MC7455 right now, you are going to need to push back through your commercial channel i.e. whoever you bought it from.

Regards

Matt


#3

Hi,

I’ve the same problem but on MC7304 where wrongly changed that PID which causes windows doesn’t recognized this module. I had managed to change back PID through ubuntu because this module still recognized in “lsusb” and “/dev/ttyUSB2” still exists.


#4

Apparently nothing that I tried worked. I tried what was recommended in this post https://forum.sierrawireless.com/t/have-i-bricked-my-sierra-mc7710/8971/1 but apparently nothing. I also tried a usb_modeswitch with no success.


#5

You are going to need to get a bespoke app generated to get it reset, that can only be done through official support channels. The previous mechanisms will not work because they were based on old architectures and commands.

Regards

Matt


#6

Try this: git.mork.no/?p=wwan.git;a=blob_ … usbcomp.pl
This user: memberlist.php?mode=viewprofile&u=42930 is the author. So maybe ask him, he has definitely the knowledge of those devices.

With Linux of course.
There is also a possibility with Windows to enable the serial ports. Probably needs modifying the .inf file to support your new USB id.


#7

Hi,

Have you tried installed this module MC7455 on Ubuntu ? I’ve done on MC7304 and believe should be work fine in MC7455 even though with wrong PID. Yes if wrongly configured for PID then shouldn’t be recognized on windows otherwise that device is already at “boot and hold” status.


#8

Boot and Hold is also recoverable.


#9

You might also try this work-around.


#10

Hi,

I just want to give my previous experiences on MC7455 where at 1st place installed on LENOVO X220/X220T running Windows 7 Pro 64 bit. Even though I’ve installed with latest Sierra drivers, this module still not recognized and at last I could see only “QDLoader Mode” port inside windows device manager. Yes “QDLoader Mode” is equivalent to “Boot and Hold” mode which means that module waiting for firmware to be flashed. With this situation, not other Sierra tools could resolve this situation and we could resolve through Linux/Ubuntu. I’ve tried installed on Ubuntu and I could see that device inside “lsusb” and “/dev/ttyUSB2” was established. I’ve followed as steps recommended for 3rd party tools where end up with “no luck” where this module was totally not recognized on ubuntu and windows. I believe you should use Sierra SDK Tools (as recommended) instead.


#11

Hi, I have a similar issue. I’ve put my EM7355 in MBIM mode using the following command:

AT!UDUSBCOMP=9

I’m actually not sure what mode it’s in because I just followed the table on page 64 of the following manual assuming that 9 is MBIM. Is there a way I can fix this in Ubuntu?

Any help is greatly appreciated!