MC7455 DHCP address

Hi all, I have a MC7455 modem, and I am running Gobi drivers S2.35N2.54. It has a AT&T SIM card.

When I connect the modem to my Ubuntu 14.04 PC, everything works properly. I see the modem eth device in ifconfig, and it gets assigned an IPv4 address after I run the connection manager app lite-connectmgrhostx86. This address seems to be not from my building network. Is this IPv4 address assigned by the cell provider to the modem?

Is there an AT command to read this IPv4 address from the modem?

The strange thing is that when I port the same drivers to my ARM design, I do not see the eth device in ifconfig. I need to specifically do a ‘ifconfig eth3 up’ to see the device. But still there is no IP address assigned. When I run the lite-connectmgrarm application code, and then do a ifconfig, there is still no IP address assigned. But then if I do ‘ifconfig eth3 down’, followed by ‘ifconfig eth3 up’, I see a IPv6 address assigned, but no IPv4 address.

Please help!! Thank you.

to read the IP address of the modem : AT+CGPADDR=1

have you tried to get the IP address for your ARM design by “udhcpc eth3”?

Thanks for the tip. I will give it a try tomorrow when I get in.

By the way, do you know what PDP stands for? I see it in the Sierra Wireless manuals but don’t see its meaning.

it means packet data protocol

Do you know where this protocol spec may be found?

I guess you can get some idea on this 3GPP spec: