MC7430 Linux QMI drivers


#1

Hi ,

I tried to install GobiNet and GobiSerial drivers. I managed to get ttyUSB0,ttyUSB1 and ttyUSB2 ports but no luck with qcqmi0 port. I installed in kernel linux 3.13 but had issues with signing module. So i installed in kernal version 4.4.0 . But still enumeration of qcqmi ports are not happening.

Thanks
Kuz


#2

Hello,

I believe certain parameters shall be commented out (please refer to that specific documents) and disable modemmanager.


#3

I did as in Linux QMI drivers guidelines. I remove modem manager and blacklisted wwan as in it. Then I recently found that when I set the module to at!usbcomp=1,1,10D

It resets to at!usbcomp=1,1,100D for some reason.

Then I realise that this causes module not to detect rmnet0 or qmi port.

Does anyone know what’s wrong

Regards
Kushani


#4

Hello,

I haven’t tried under Ubuntu but did try under Windows Environment. just for testing I’ve tried change ATI!USBCOMP=1,1,50D or ATI!USBCOMP=1,1,100D and believe “100D” as for MBIM and “50D” as for QMI. Have you tried change again ATI!USBCOMP=1,1,50D ? Believe this parameter for QMI.


#5


Hi,

I did setup to at!usbcomp=1,1,50D . But still can’t see qcmi0 in /dev/.

However when I dig in dmesg log, I can see GobiNet driver get registered but it failed mentioning "Failed GET_NTB_PARAMETERS
(I have attached the log here)

Anyone know the issue?

Regards
Kushani


#6

That error comes from the cdc-mbim driver. The fact that it attempts to bind, and that there is an interface number 12, shows that MBIM is still enabled. So you have not successfully switched the modem to qmi.

I don’t know why the mbim driver fails to get the NTB parameters. That is unexpected. It could possibly be because something else has tried to speak qmi to this function first. But that is just guessing. It could also be because the firmware is completely broken. There are too many weird and unexpected issues here.

EDIT: I noticed that the qcserial driver binds too, which clearly shows that you haven’t followed the QMI SDK guidelines. So I’ll just assume that you also screwed up the other things you claim to do.


#7


HI,

Yeah ur comments make sense to me. Now I managed to get Gobi Serial interfaces as you can see here.

But the thing is I set the modem at!usbcomp=1,1,50D(Diag,nmea,modem,rmnet0,rmnet1). Then I reset the modem.

So I haven’t activate the mbim interface.

So I wonder why I can’t see qcqmi ports and able to see mbim .

Is there anything wrong with the command?

Regards
Kushani


#8

Hello,

I’ve EM/MC7455 modules where installed on DELL Latitude E7270/E7240 running on windows 10/Ubuntu environments. I believe “ATI!USBCOMP=1,1,100D or AT!USBCOMP=1,1,50D” not an issues. Under Linux/Ubuntu environments, besides add two (2) “blacklist qcserial blacklist qmi_wwan” and remove modemmanager for system, you’ve to make sure “make” and “sudo make install” are fully working under “GobiSerial” and “GobiNet”. I’ve an experience where both are working fine under Ubuntu prior to version 17.04 but under Ubuntu Version 17.04 got problem especially for “GobiNet” where “make” was not working. As I said I’m just an ordinary and not so important to me.


#9

Hi,

I blacklist both and issue sudo kill -9 Modemmanager. I have 16.04 Ubuntu and GobiNet and GobiSerial drivers were installed successfully.

I think my module has issues in switching to QMI mode.

Thanks for your comments.

Regards,
Kushani


#10

Hello,

I believe you could access that “/dev/ttyUSB2” via any linux tools (minicom) to access modem. If could access the you can initiate below commands

ati
atz
at!entercnd=“A710”
at!usbcomp?


#11

Hi,

I already setup the module to QMI mode using at!usbcomp=1,1,50D from host machine(In my case windows)

But for some reason it resets the configuration it self after I reset the module.

( I did the rest as the change to take effect )

Regards
Kush


#12

Hi all,

All solved under ubuntu 16.04.03

Regards,
Kushani