logread doesn't work

But it doesn’t work:

(just logread without the ‘-f’ also gives the same)


This is with Legato 14.04

Did you upgrade your board following the instructions provided by: legato.io/legato-docs/14_04/ … Legato.htm?

If not, follow the instructions provided under ‘Update firmware’.

Once that is complete, you’ll also need to update your Yocto. Download the prebuilt image files from legato.io/legato-docs/14_04_ … octoImages).

If your Yocto has been updated correctly, you should be able to see a process (/sbin/syslogd -C200) that will allow you to use logread and read the Legato logs.

Ah - no, I haven’t.

Since the 14.07 is already available, can I upgrade straight to that - or do I need to do the 14.04 upgrade first, then 14.07 from that?

Again, is there an upgraded USB stick image available to down load - rather than have to wade through the process manually?

In fact, I can’t seem to find the old USB stick image (in case I mess it up) - I thought it was going to be made available to download :question:

You may upgrade straight to the latest, but there isn’t a target upgrade yet for 14.07. But it should be out soon.

If you want to wait, we can always try the following workaround (although I’m not sure if it will work).
On target, run the following commands:
root@swi-mdm9x15:~# pidof syslogd (this should return a number)
root@swi-mdm9x15:~# kill (pass in the num returned from the previous command)
root@swi-mdm9x15:~# /sbin/syslogd -C200

Now try logread.

It actually returned three numbers

So I did a kill on each one

Yes - now it works. And I can see my “Hello, World” entry.


Would I need to repeat the exercise after a restart?

Yep. But the later version of Yocto will have this configured for you by default once you upgrade. Glad this workaround worked for you! :smiley: