LINK_LOSS occurs after MUSIC 10 PLAY

I have my BC127 set up in A2DP Source mode and I have another Bluetooth sink device to play the audio (I have tried my Bluetooth headphones as well as a BC127 discovery board in A2DP Sink mode). I can pair with the devices fine, but when I use the command MUSIC 10 PLAY, the audio plays for a brief second and then immediately stops due to a LINK_LOSS 10 1 & LINK_LOSS 10 0. I have monitored my input voltage and I can see there is no drop in voltage when I press send the command. The audio signal I am sending in is a sinewave which results in a 920mVpp input waveform on the audio input (I have also tried a smaller input voltage, but the result is the same).
The settings I have set for the BC127 are:

SET PROFILES=2 0 0 2 2 3 2 1 0 0 2 0

Does anybody have an idea what might be causing this annoying LINK_LOSS?

I found the issue. The problem was interference from my oscilloscope when it was powered on. Just a heads up to anybody else using an oscilloscope in proximity if you start to see weird behavior.