IPv6 and ECM data connection with a HL8548 modem

Hello everybody,

My aim is to use the CDC ECM data connection to establish a data connection between a HL8548 modem and a Linux system.

I do it successfully with an IPv4 address, but I also need to do the same with an IPv6 address, and unfortunately it does not work.

Here is what I do:

  1. I use minicom on the ACM device to run the following AT commands:
    a. Context configuration: AT+CGDCONT=1,"IPV6","<APN HERE>"
    b. Data activation: AT+XCEDATA=1,0

  2. Both of the above commands returns OK; so I am able to enable the network interface with the command: ip link set eth1 up

At this point, I’m a bit lost. To get an IPv4 address, I had to run a DHCP client on the interface. But with the IPv6 address, everything looks OK:

eth1      Link encap:Ethernet  HWaddr 00:00:11:12:13:14
          inet6 addr: fe80::200:11ff:fe12:1314/64 Scope:Link
          inet6 addr: 2a04:cec0:a02:562a:200:11ff:fe12:1314/64 Scope:Global
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:256 (256.0 B)  TX bytes:496 (496.0 B)

Also, the context looks fine too: +CGDCONT: 1,"IPV6","<APN HERE>","",0,

Unfortunately, all ping or curl commands fail. I tried to run a dhcp client (dhclient -6 eth1) but nothing happened.

I am sure that the SIM card is IPv6 complient.

I confess that I have a very poor level on network and modem communications. So maybe the issue is obvious, but I have no ideas.

Can someone explain me what is wrong in my procedure, and how to fix it please?

Thank you in advance!

Hi @semurel ,
Have you tried set dynamic DNS request by command
AT+XDNS=1,3 (Enable dynamic DNS request (IPv4v6))
Also, the module should be upgraded latest build which provides full supported features and fixed

Hello @Vianney, and thank you for your answer.

Indeed, the module was not in the last version, so I have updated the firmware with the last update (RHL85xx.

Unfortunately the commands above seems now broken.

When I use the AT+XCEDATA=1,0 command, I have a CME error 148 (from the manual: “Unspecified GPRS error”).

And when I try to run it a second time, I have a CME error 4 (“Operation not supported; parameter is out of range”).

Another weird thing, it seems that the context has an IP address:
+CGDCONT: 1,“IPV6”,"",“”,0,0

But my interface still doesnt work (it has no more IP).

Maybe I do something wrong?



I have just tested this on 5.5.26 and it works fine.

I updated the unit before I did it and what you might have an issue with is the kusbcomp setting might have been reset to 0 in the upgrade, it needs to be set to 1 to enable the ethernet interface and enumerate properly to the system.



Hi @mlw,

I tried to send a KUSBCOMP and then a modem resetting before sending the same commands, but the issue still occurs (same errors).

You confirm you use the same commands as me and that you can ping something with an IPv6 address on your interface?



Sorry mis read the initial post. Couple of points.

  • I am not aware of anyone deploying IPv6 on 3G, what network is this?
  • I can’t test that as I certainly do not have access to an IPv6 deployed network, not even sure if test kit does this.
  • We will not have tested IPv6 and this functionality and I don’t think it would work either.



The network is Bouygues Telecom (French provider). I think the IPv6 is avaible on their network, because I already saw an IPv6 address on my Android phone.

But as I said I have a poor level about UMTS communications so maybe I have misunderstanding something.