how to use the gps option in MC 8790?


#1

I’m connecting the ant to AUX (in the modem)
then I’m trying to get GPS location , and nothing

what do I didn’t do?
this is what I get:

at!gpsloc?
not available !

Thank you,


#2

Hi David,

To have GPS to work, various condition has to meet (e.g. sky, antenna, etc), but first thing we should check if GPS was enabled by sending “AT!CUSTOM?”.

We expect “GPSENABLE” is “1” and no “GPSLPM” there, also note that it may take short time to have first fix (TTFF).

If you are using Watcher, you can configure the GPS mode(Standalone/MS-Based/MS-Assisted) and to start the fix/tracking.

In case you are using AT command, please refer to section 9 of Extended AT command guide.

P.S. I believe this question should be instead raised in forum: “MC Series”.

Hope it helps.


#3

Thanks

but still not working
I did enable=1
but when I do
"
at!gpsloc?
Not Available
OK
"

the ANT is on the roof.
also didn’t find section 9 of Extended AT command guide.
and on the Watcher or in the discovery kit - when I open the GPS Monitor it’s said - “Could not start session”.

anyone?


#4

Never mind -
Problem solve!


#5

So how about sharing the details of how, exactly, you solved this problem :question:


#6

sure -
need to do :
AT!GPSENABLE=1

make sure the version is
K2_0_7_35AP C:/WS/FW/K2_0_7_35AP/MSM6290/SRC 2010/03/04 17:37:08

/system gps set enabled=yes port=usb2 channel=2 set-system-time=yes

then:
at!gpsautostart?
enable: /
fixtype: 1
maxtime: 180 seconds
maxdist: 50 meters
fixrate: 1 seconds

This is all
my mistake was , I didn’t wait 180 for it to start working (lucky I needed to pee…)

hope it’s help