HL8548 sometimes cannot call, send SMS

I am currently using HL8548 to develop my application. The basic function as call, SMS works well for a long time until my boss using the product and goes somewhere.
The problem is sometimes my boss cannot call and send SMS although the previous time he can, I have to view the log: when starting a call, it respond “NO CARRIER”, sometimes it just respond “+XCALLSTAT: 1,2” then doesn’t respond anymore.
I have tried to fix problem by send AT command: “AT+KSRAT=1” or “AT+KSRAT=2” or “AT+KSRAT=4”, it can work well, and sometimes these command doesn’t respond. The problem sometimes I meet in some modules and very confuse for us.
The firmware we are using is: RHL85xx.
I need your help. Thank you very much!

Hi @toan_tran123,
Which CLIR value you set for HL8548? Please try below and make call


Please share any concerns you have. Help us tick Solution if your problem is solved

Hi @Vianney,
I think my module is not attached to the network. With your help, I have tried “AT+CLIR?” and it responds “+CLIR: 2,0”

Hi @toan_tran123,
Please check network registration and operator selection by command below
If the response of cgreg? isn’t 1 or 5, your module has not registered successfully. Please double check your SIM/operator

1 Like

I will check your command if the module meets the problem. Sometimes, I fixed the problem by sending “AT+KSRAT” or reboot the module but this inconvenience for user, I am finding new solutions to fix it.

The write KSRAT command automatically reboots the module to force a re-initialization of the radio with the selected RAT so I guess your issue is gone after reboot module action. Please share any concerns you have and help tick Solution if your question is answered

I need to reboot the module in some cases it work not as expected.
Thanks for your help.