HL7812 not responding to AT command requested

We are working with HL78xx development board with Jio 4G sim.
To switch to GSM mode, I tried the command “at+ksrat=2,1” after which the board is not responding to majority of the AT commands including simple “AT”. Few AT commands we noticed that is working are
I tried to perform the factory reset using “AT&F” command but that doesn’t seem to be working, can anyone please let us know how to recover the chip without fresh firmware upgrade.

Hi @jeshwanthng
Welcome you to our community!
According to the AT Command Reference Guide, when you switch to GSM mode with command “at+ksrat=2,1” then the module will reboot.
Did you wait for the module to reboot? or after typing command “at+ksrat=2,1” then you type other commands?


Hi @jerdung
Thank you for the quick reply and it’s great to be part of your community,
After “at+ksrat=2,1” command I entered “at+cfun=1,1” command, but I don’t remember
if was waiting for the device to reboot or not.

Hi @jerdung, can you please help me out in resolving the issue as I am completely blocked.

Hi @jeshwanthng ,
Please unplug the module and plug it back in then check if your computer still receive the port from the module?