Help with MC7455 in OpenWRT router

#121

I don’t think the blogpost says that.

You can either look in the kernel log (MBIM device at …) or (QMI device at …) or in the USB composistion AT-command.

QMI:

AT!ENTERCND="A710"
AT!USBCOMP=1,1,10D

MBIM

AT!ENTERCND="A710"
AT!USBCOMP=1,1,100D

For location: Do you mean GPS? If yes you can always use the serial port to get NMEA location info.

0 Likes

#122

Thank you for the information about mode switching. Meanwhile I’ve been trying to find answers to my other questions myself and found out that my modem is in fact in QMI mode, and the reason MM’s location support is not working even though in QMI mode is because the MC7455 is using a newer QMI protocol (LOC) instead of the older PDS service, which MM/libqmi doesn’t support yet. (I can still start MM in debug mode and issue AT-commands by hand using mmcli to get location data, but it would have been so much nicer and possibly more reliable to get these information from MM. I’ll investigate if I can supply a patch to MM.)

0 Likes

#123

Hello, I am the OP that needed help setting up my router and modem to work with Sprint. When Verizon brought back the unlimited plan, I added a line to my Verizon plan (using an old Note 3) and then switched the sim card in the Linksys router from the Sprint card to the Verizon card and changed the bands. Everything was going fine since I switched this last February. Then, when my most recent billing period began, my setup is now considered a “hotspot” according to Verizon. I have unlimited data, but only a max of 15GB of hotspot data to use each month. Well, I went through the entire 15GB the first day and Verizon has now slowed that connection down to 600kbps for the rest of the billing period. I installed the sim card back into my Note 3 and using 4G on that works fine, no slow down. I put the sim card back into the MC7455, and it immediately went back to 600kbps. Am I now screwed? Is there any way to stop Verizon from thinking this is a hotspot? Can I change the mac address in the modem or do I have to buy a new modem? I don’t want all this time and money spent to be all for nothing.

Thanks.

0 Likes

#124

Your phone uses a TTL of 64. Many carriers look for this and if it’s over then it will show up as a hotspot. Computers show yp as a ttl of 128 normaly and this is a red flag. To set a ttl on your router go to network then firewall then custom rules. Add this line after all the hashed lines and save. This will force all ttl to show up as 64 after it goes through the mc7455. This might or might not work.

iptables -t mangle -I POSTROUTING -o get_wanface -j TTL --ttl-set 65

0 Likes

#125

I will try that, but, isn’t the “modem” between the tower and my router? It was my understanding that Verizon does not see my router, only the modem which receives the 4G signal. Can the TTL be changed on the modem?

0 Likes

#126

Your client is what determines the ttl. The script I gave you makes all devices use the ttl that Verizon wants to see. It’s the same ttl that would be on the phone by itself.

0 Likes

#127

Just so I’m clear…this line should have a 128 at the end and not a 64?

iptables -t mangle -I POSTROUTING -o get_wanface -j TTL --ttl-set 128

0 Likes

#128

No. It should be 65

0 Likes

#129

I got it to work!!! Thank you! Here’s what I used:

iptables -t mangle -I POSTROUTING -o wwan0 -j TTL --ttl-set 64

Should I still change it to 65 even though it worked?

My speeds were 0.6 before the change and 30 after, at least on my PC. My iMAC is a different story. Both computers are connected to the same ethernet cable via a switch so there shouldn’t be any difference in the signal. Speedtest on the iMAC, however, still won’t go above 0.6. It follows the same route as my PC…through the Linksys router running OpenWRT connected to the MC7455 modem. Any ideas why this might be happening?

I tested the speeds on my phone connected to the Linksys router and got 30 download also.

0 Likes

#130

Try both and see.

0 Likes

#131

I changed the value from 64 to 65…

iptables -t mangle -I POSTROUTING -o wwan0 -j TTL --ttl-set 65

…and my iMac’s speed immediately jumped up to normal speeds.

Thank you for helping me out. I hope this is a permanent fix for the “hotspot” problem.

0 Likes

#132

I have a Mikrotik 912UAG-5HPnD-OUT running LEDE 17.01.4… I have a mPCIe Sierra MC7455 card in the slot on the router board with an ATT SIM installed as well. I’ve been searching, reading and trying all steps I could find, but I’ve not been able to figure out how to configure this card. So far, here is what I see:

oot@LEDE:/dev# dmesg | grep usb
[ 4.019693] usbcore: registered new interface driver usbfs
[ 4.025357] usbcore: registered new interface driver hub
[ 4.030931] usbcore: registered new device driver usb
[ 10.727496] usbcore: registered new interface driver cdc_wdm
[ 10.873640] usbcore: registered new interface driver usbserial
[ 10.879752] usbcore: registered new interface driver usbserial_generic
[ 10.886481] usbserial: USB Serial support registered for generic
[ 10.962841] usbcore: registered new interface driver cdc_ncm
[ 11.115515] usbcore: registered new interface driver qmi_wwan
[ 11.123880] usbcore: registered new interface driver sierra
[ 11.129736] usbserial: USB Serial support registered for Sierra USB modem
[ 11.139485] usbcore: registered new interface driver sierra_net
[ 11.174805] usbcore: registered new interface driver cdc_mbim
[ 11.187634] usbcore: registered new interface driver option
[ 11.193487] usbserial: USB Serial support registered for GSM modem (1-port)
[ 11.206390] usbcore: registered new interface driver qcserial
[ 11.212422] usbserial: USB Serial support registered for Qualcomm USB modem

====================

root@LEDE:/dev# ls
bus mtdblock0 ttyS13
console mtdblock1 ttyS14
cpu_dma_latency mtdblock2 ttyS15
full mtdblock3 ttyS2
hwrng mtdblock4 ttyS3
kmsg mtdblock5 ttyS4
log mtdblock6 ttyS5
memory_bandwidth network_latency ttyS6
mtd0 network_throughput ttyS7
mtd0ro null ttyS8
mtd1 port ttyS9
mtd1ro ppp ubi0
mtd2 ptmx ubi0_0
mtd2ro pts ubi0_1
mtd3 random ubi0_2
mtd3ro shm ubi_ctrl
mtd4 tty ubiblock0_1
mtd4ro ttyS0 urandom
mtd5 ttyS1 watchdog
mtd5ro ttyS10 zero
mtd6 ttyS11
mtd6ro ttyS12

I don’t know what else to do. If anyone can assist me, I would greatly appreciate it. Thank you!!

0 Likes

#133

Very interesting! Thanks you

hgkjlkl

0 Likes

#134

QMI LOC based support in MM is a reality (working for devices both in QMI or MBIM mode), see https://gitlab.freedesktop.org/mobile-broadband/ModemManager/merge_requests/10

0 Likes

#135

Thank you for your notice. We will try it out a bit later, at the moment we are debugging a different problem that is unrelated to MM. I will let you know of the results how well the new LOC support is working.

0 Likes

#137

My apologies if this is the wrong section for this but i recent got a WG3526 router that supports the linux-based OpenWRT firmware. I also installed a MC7455 module which allows one to get internet access from a SIM card. Although I have gotten it to work and i can access and adjust settings within openwrt i notice the internet is unstable. When i jump to different sites it will work just fine but then suddenly at random whe i revisit some of those visited sites again, after not visiting them for a while, then the sites will either return 404 or return back partial. For example, if i visit some visit some investment sites like say this questrade review or even cnn when i start my 3526 from a cold boot then both will come down perfectly …but then lets say i begin playing videos on Youtube for a while, but then i return to the review or cnn…when i do that those pages will either return 404 or come down partially. I could then quickly jump to any other site (that i haven’t visited before) and it will work just fine. So it’s not that the router is experiencing some hiccup at that exact moment since if it was, that page should come down as a 404 or garbled too but they don’t.
for ore information about jobs visit here careerjobs360

0 Likes