Help with MC7455 in OpenWRT router


#41

Yes. The v8 firmware will work too and some say it works better than the v9. You’re going to just have to try it and see what works for you.

Do the v8 sysupgrade and the mbim.sh swap and it should work.


#42

I reloaded v9 and I got it to work!

Now I can’t get the Wi-Fi to work. I followed the instructions for setting up Wi-Fi on the openwrt website but no matter what i do I can’t get an internet connection through the Wi-Fi. This is so frustrating! Are there drivers I need to load for the Linksys WRT1900ACS?


#43

No need for extra drivers. Just a misconfiguration I guess.


#44

It’s not a misconfiguration. I know how to set up Wi-Fi on routers, I’ve been doing it for years. There has to be something else I’m missing.


#45

Adjust the width of the 2g and 5g radios in the settings. This has happened to me before on a different router and it brought wifi to life. Also are you absolutely positive you flashed using the 1900acs and not the 1900ac firmware?


#46

I’m 99% sure I used this one to update but I will sure check my downloads folder when I get home.

lede-v9-mvebu-linksys-wrt1900acs-squashfs-sysupgrade.bin

I tried to use v8 like you said, but never could get any ttyUSBx in /dev. So I flashed back to v9…didn’t change anything except run the uci commands and I was able to finally get on the internet. I think when I had v9 loaded before I had forgotten to remove my other router’s gateway ip from the lan settings after installing packages. :confused: :unamused: oops

I tried various combinations of 2.4GHz and 20/40MHz and also 5 GHz and 20/40/80MHz. I will keep trying but thought I might be missing a key driver for the radios.

Again, thanks for all your help. I was super excited yesterday when it finally connected!

BTW, one big reason I’m doing this project is that my Sprint 4G signal coming through my Netgear 6100D router would drop randomly. I mostly assumed it was due to the crappy router. Initially I would lose connection every few minutes and finally figured out it was the 5GHz radio causing it and had to disable it. But even after that I would still randomly lose internet. Sometimes the router log would have a bunch of crazy error messages and sometimes it would just say registration lost. Do you have any of these issues using your current setup?


#47

About once or twice a day I will get a random drop but set watchcat up for 30 sec and it will fix itself. Mine sits in a room and I don’t touch it. Its self fixing. There is another reconnect.sh that the germans use in that forum that reconnects you within 10 sec if there is a problem but I haven’t messed with it yet.


#48

What AT command is there to see if I have been issued a wan ip address? Or is there somewhere in the openwrt software that I can see this?


#49

I am not aware of such an AT command.


#50

Just look in your router logs. It will show after the mbim setup the ip of wan.


#51

I was able to get the wifi to work. I had to check the box next to wan in addition to lan in the wifi settings. The instructions I looked at didn’t have it checked, but I guess it makes sense to have it checked.

The 5GHz wifi doesn’t seem to be very strong and my SNR drops almost to unacceptable levels when in the next room.

When on lan or relatively close to the router on wifi, my speeds have been in the low 30’s during off peak times which is roughly 10Mbps or more than I used to get with the Netgear 6100D.

Would it be possible to get the code of your watchcat to automatically reconnect the signal?

My other issue is that I have to keep this router in an upstairs bedroom closet. That is the best signal reception spot I could find after testing all over the house. That location is good for the bedrooms upstairs, but not for the rest of the house, so I would like to also use my Netgear Nighthawk on the main floor as a second wireless router. What is the best way to set this up to avoid double NAT and latency issues?

Thanks to all for your help!!


#52

Just download watchcat package and the luci watchcat package. Set up pings at 15 sec and reboots at like 30 sec.

Change the settings, widths, and channels on your wifi to get better ranges.

The netgear nighthawk has a wireless bridge option on the factory firmware. Just have to set it up. Should just be a couple clicks. It might be slower because it will be half duplex.

Best would best would be to wire them together instead of wireless then you wouldn’t lose bandwidth.


#53

Sorry, I left that part out. They will be connected via lan cable. I ran a lan out the side of the closet outside and around the house and back in where the cable tv enters house.

I want to be able to have the kids upstairs connect to the wifi from the Linksys upstairs, and people on main floor and in basement connect to wifi coming from Netgear (most likely on a different subnet). I just don’t know how to do this without the whole double NAT thing.


#54

Lan out of openwrt router to one of the 4 Lans of the netgear. That’s it. Just don’t use the wan. You can disable dhcp in the netgear also. Then set the gateway to the linksys gateway. Probably 192.168.1.1

But before you do all that I really think in the netgear nighthawk firmware its just a one click deal and it takes care of it for you and even turns the wan into a lan.


#55

Don’t connect the devices via their “WAN” port. Only one DHCP should be active on the network.

Edit: too late


#56

I edited my original post to add in the band locking and getting signal info directly from the luci interface. I’ll post it here too

Custom commands can be used to switch bands and show status directly from the router. You will need the luci app commands package installed.

Place the attached files into /etc/gcom in winscp

dropbox.com/sh/y39e18ferj5a … iDlYa?dl=0

in luci under system /custom commands/ configure put in a description such as “Lock Band 41” then use this command
gcom -d /dev/ttyUSB1 -s /etc/gcom/Band41

“Lock Band 25” then
gcom -d /dev/ttyUSB1 -s /etc/gcom/Band25

and so on for each file using the correct capitalization.

again im not sure which usb your modem is on so you may need to change it.


#57

So the issue I’m having now is when I randomly lose the internet signal (unknown whether it’s due to the router, modem, or signal from Sprint tower), I have a hell of a time getting my internet connection back.

Problem: every time I reboot the router comes back up with the wrong date and time. This causes the initialization with the modem and LTE signal to not work properly (I’m assuming). I sync the date/time with my browser, save and apply, but it’s wrong again on reboot.

So what I have to do is:
1. Disconnect the USB modem
2. Reboot router
3. Sync router with browser date/time
4. Wait a bit, then plug in the USB modem and hope it connects (sometimes it does and sometimes it doesn’t)

How can I get the router to update to the correct date/time if I cannot get my internet connection properly without the correct date/time? It’s the chicken and egg conundrum…which came first?

This is not something my wife and children would even begin to comprehend if I wasn’t home to fix it. It went out the other day and I spent over two hours after I got home from work trying to get my internet signal back!

Please tell me there is an easy fix for this. :angry:


#58

I know exactly what you’re talking about. It’s only happened to me a few times so I never bothered looking into it but it has something to do with the mc7455 not booting up fast enough. Next time reboot from within the router and that will keep the mc7455 on and it should fix it. I’ll look into that time error deal also. I’ll ask around.
Also, are you using watchcat for your reconnection?

This is the error correct?

cron.err crond[976]: time disparity of 851496 minutes detected


#59

I always tried rebooting it with the modem connected but that never works. It always comes up with wrong time. Sometimes it’s the current day but most of the time it’s the previous day. I get that error once I changed to the correct date and time. But then it never gets my internet connection back by just syncing the correct date and time with the modem already connected.


#60

Are you sure it’s not a signal issue? Are you locked into a specific band? Are you using the watchcat reconnect package?

I’ve heard that the v8 firmware is better than the v9 because of the issue you are having. V9 works for me but not all routers are the exact same. Do a sysupgrade to v8

But the watchcat pings google every 15 sec keeping an active connection all the time and if it goes 30 sec without a connection it will reboot.