Help with MC455/MC7430 in mount USB ports in Raspberry Pi 3

I use MC455/MC7430 in Raspbian. I don’t know some MC devices not mount full USB port (normaly 3 ports). I just see the device mount to /dev/ttyUSB1 with ID_USB_INTERFACE_NUM=00.
Update here a log which captured from my PI:


I check all my MC devices, some devices work and some devices is not work. So, problems about environment or drivers can be ignored.
How to reset device to device mount full USB ports?
Have any solution to I work aground to device work again? Could solder PIN of MC devices to USB port and plug it to PC to flash again?

you need to use GobiSerial driver instead of qcserial driver.

Hi jyijyi,
I replace qcserial driver to GobiSerial but the issue like qcserial still occurred.

is this related to power issue as you said some module has no problem ?
/dev/ttyUSB1 has no such error message but it disconnects eventually.

I use other MC7455 which fine working. The MC7455 mount 3 USB ports (/dev/ttyUSB1, /dev/ttyUSB2, /dev/ttyUSB3). But I use the device which have above problem, it just mount a USB ports (/dev/ttyUSB1).
Do you have solution to the MC7455 mount 3 USB ports like device working fine?

to have three USB ports, you need to check/set AT!usbcomp

1199:9070 is a bootloader device ID. It is expected to have only one serial function on USB interface #0. No driver juggling is going to change that, ever.

What you might want to ask is why the MC7455 isn’t booting. This is a firmware issue on the MC7455. But the root cause can be anything from hardware errors and NVRAM issues to a simple missing firmware. If you’re lucky, then reinstalling the firmware might fix it. That’s the first thing I would have tried.

Your root cause mentioned at here is right. Before pushing the question on here, I tried to reinstalling the firmware for some devices and it were work again.
Devices can mount to serial port is /dev/cdc-wdm port, I used qmi-firmware-update tool to update firmware, and it’s work again.
But some devices can’t mount /dev/cdc-wdm port, I can’t use qmi-firmware-update tool.
Do you have a other solution to reinstalling the firmware?