Help with gps


#41

Didn’t you know that Wavecom modules have Windows XP on board?! :laughing:


#42

With no open-AT application installed, have you tried using Hypoterminal (or whatever) to verify that you can send AT commands to UART2, and receive its responses?


#43

Not exactly but I tried another way… I connected an oscilloscope to the edges of RX and Tx of the GPS and I saw that the GPS sends pluses (ie data) and the UART also send pulses to the GPS Rx!So that is supposed to mean that they communicate properly, right?


#44

Did you verify that the “pulses” constitute valid frames?
ie, correct baud rate, correct start & stop bits, parity, etc…


#45

Yes everything is ok with this! And while at first UART2 responded and sent something back now it sends nothing at all…
I only use RX and TX and I disabled RTS and CTS because my GPS doesn’t provide any. My oscilloscope shows the data coming from GPS ok, but the UART2 doesn’t seem to “feel” anything although I opened it and set the corrected baud rate… (also I used AT+IFC=0,0 to disable CTS and RTS). Any ideas please??


#46

I found what the problem is… GPIO1 which I use to enable the GPS was never driven high, so UART2 was reading trush …


#47

I want UART1 to be in data mode.

Once data receives on the UART. I should receive an event.

Can any one explain how to achive this.

I am new to wavecom OPENAT