GR64 commands fail on Q64


#1

We were using a GR-64 module, but have now been supplied with a Q64 which should be compatible. I have read the manuals and the posts on this page, but I have not been able to get the Q64 module to accept any GR 64 commands.

I have also attempted to use WMP 100 commands, and this works except I get a option error when attempting to start the GPRS berrier.

The version has been tested and found to be:

AT+CGMR
R73a00gg.Q64001 2094168 032009 12:40

as suggested by a post on this site.

When I execute

ATE2SSN
ERROR
AT
E2SSN=?
ERROR

And in the compatibility manual it says that there should be no difference. Naturally I have tried other commands.

As suggested in another post I have used AT+WOPEN to test and activate the plug-in. Here is what I get:

AT+WOPEN?
+WOPEN: 1

OK
AT+WOPEN=7
+WOPEN: 7,12

OK

So the plug-in should be activated and running. I tried restarting it with no effect.

Does anyone know what the problem might be?

The module is a TS-GSM1 from Technologics, but they say they were just told that they were compatible.


#2

I have the Q64 but I don’t use the compatibility plugin. Never got it working right. Use the command AT+CCID to get the SIM id number (gr64 e2ssn). You will have to wait until the sim has been initialized to get that number though. I wait for the ADL_SIM_EVENT_FULL_INIT event, and then issue the AT+CCID command.