GPRS Connection Failure in Sierra SL Series Modems SL8082BT

We are using Sierra-based SL Series Modems (Open AT) for our energy meters to communicate data to a RabbitMQ Broker Queue. The data is received as RF Zigbee payload and then sent to RabbitMQ Queue . The modem performs several steps on power-up to establish a GPRS connection, including SIM registration and GPRS Barrier configuration. However, we are facing a recurring issue with the modems failing to obtain a SIM network IP, resulting in a GPRS Connection Failure with error number -36


  1. Error Description:
  • The modem is unable to get a SIM network IP.
  • Error: GPRS Connection Failure, Error Code: -36.
  1. Field Deployment:
  • 229 devices installed across various locations.
  • Approximately 10-15 devices go out of network weekly.
  • Devices often return to the network after a power reset or SIM replacement.
  1. Diagnostic Observations:
  • Device A fails at location A but works when moved to location B.
  • Device B consistently works at its location and does not face network issues.
  • Issue persists despite multiple soft resets; sometimes resolves with a hard reset.
  • Devices with new SIM cards reconnected successfully within 72 hours.

Request for Assistance:

  1. Potential Causes:
  • What could be the underlying cause of the GPRS connection failure and the error code -36?
  1. Troubleshooting Steps:
  • Are there any recommended steps for further diagnosing the issue?
  • Would firmware or hardware modifications potentially resolve these intermittent connectivity issues?
    Please do the needful.
    Thanks in Advance!

which FW are you using?

for the bearer error:

could it be related to SIM?
Have you put the problematic SIM to another good device?

R7.54.0.A1.201603171313.SL8082BTR 1997208 031716 13:13

“DWL”," C04.05.14.00.SL8RDBT R2684 CNSHZ-ED-XP0031 2015/11/05 21:36:55",“”,“Sierra Wireless”,0,“”,“00000000”,“00000000”
“FW”,“FW_754_0_A1_22_1.SL808FAx”,“R7.54.0.A1.201603171313.SL8082BTR”,“Sierra Wireless”,1997208,“031716 13:13”,“a887779d”,“10002020”
“MODEM 3G+”,“Revision: C04.05.14.00.SL8RDAP R2684 CNSHZ-ED-XP0031 2015/11/05 21:36:55”
“OAT”,“”,“”,“”,215664,“081023 13:31”,“43df8f91”,“10700000”
-“Developer Studio”,“”
-“Open AT Application Framework package”,“2.54.2.A1.201702240946”
-“Open AT OS Package”,“6.54.3.A1.201609080909”
-“Firmware Package”,“7.54.2.A1.201701061226”
-“ExtendedATApplication Library Package”,“3.2.0.A1.201610211044”
-“eCall Library Package”,“”
-“Local Trace Session Library Package”,“”
-“Location Library Package”,“”
-“AirVantage Agent Library Package”,“5.3.6.I201504101620”
-“Security Library Package”,“”
-“Internet Library Package”,“5.58.3.A1.201610210959”

+WOPEN: 2,“AT v06.54A1”,“AT v06.54A1”

could it be related to SIM?
Have you put the problematic SIM to another good device?

Error Log

2024- 3-20 0:50:56 WIP_BEV_CONN_FAILED,11,-36
2024- 3-20 0:50:56 default Soft_Reset
2024- 3-21 18:19:48 wdt_return_value = 0
2024- 3-21 18:19:48 ADL_INIT_POWER_ON
2024- 3-21 18:19:48 flhSubscribe ADL_RET_ERR_ALREADY_SUBSCRIBED
2024- 3-21 18:19:49 before GPRSInit() in poll_creg_callback
2024- 3-21 18:20:25 WIP_BEV_CONN_FAILED,0,-36
2024- 3-21 18:20:35 before GPRSInit() in poll_creg_callback
2024- 3-21 18:20:35 The device is already opened

If we use the same SIM card in another modem its working Fine, we are using STATIC IP based SIM cards which means IP will never change. but before getting this error SIM connected to GPRS and it working fine, after some days or some time we are getting this -36 error message.

as a workaround, you can do software reset when receiving this error

Yes we are doing that, by giving at+cfun=1, but still no result.

what do you mean by “no result”?

Not Connecting to GPRS.

wip_bearerGetOpts(b, WIP_BOPT_ERROR, &wip_error_code,WIP_BOPT_END);
adl_atSendResponse ( ADL_AT_UNS, wip_buff );

	//debuglog("wip_bearerStop @ WIP_BEV_CONN_FAILED");


	if (gprs_conn_fail >= 12)     //15 min //2mins==12 assumed

adl_fcmSendData((u8)FCM_Handle,(u8 *)“Restart due to CONN_FAILED” ,strlen(“Restart due toCONN_FAILED”));
uGPRSFlag = 0;
c = NULL;
//adl_fcmSendData((u8)FCM_Handle,(u8 *)“WIP_BEV_CONN_FAILED OK\r\n”,20);
adl_fcmSendData((u8)FCM_Handle,(u8 *)wip_buff,strlen(wip_buff));
adl_tmrUnSubscribe (blinkled,meter_io ,ADL_TMR_TYPE_100MS );
blinkled = adl_tmrSubscribe ( TRUE, 20, ADL_TMR_TYPE_100MS, meter_io );
adl_tmrSubscribe(FALSE, (CREG_TMR_SEC * 10), ADL_TMR_TYPE_100MS,poll_creg);

I think you don’t need to wait for 12 times

Its not 12 Times, we are waiting for 2 mins to do the reset. after receiving the -36 error message.

then does it work???

No The result is same “Getting Error 36”.

Can we restart the OpenAT application by AT+wopen=0 and AT+Wopen=1 ?

  1. Already OpenAT application is running in modem, is there chance to stop and start the OpenAT application?
  2. If it is there how can we implement in source to stop and start the application?
  3. Can we get ant example or related links also fine.
    Thank you!

Q1: You can restart the application by AT+wopen=0 and AT+Wopen=1

Q2: no, you cannot, but at least you can know if issue solved by restarting openat application

Ok will try this way.
Thank you.