GPIO44 not available in Firmware R7.2


#1

Since I updated the Q2687Classic to (R72_00gg.Q26CL701 2045812 081808 17:44), GPIO44 is no longer available.
This pin is multiplexed with 32Khz, but even after disabling 32KHZ clock through AT+WHCNF=2,0 I don’t have GPIO44 back. I appreciate any help.
The list of current available GPIOs is below:
AT+WIOM=2
+WIOM: “GPIO0”,4
+WIOM: “GPIO1”,4
+WIOM: “GPIO2”,4
+WIOM: “GPIO3”,4
+WIOM: “GPIO19”,4
+WIOM: “GPIO20”,4
+WIOM: “GPIO21”,4
+WIOM: “GPIO22”,4
+WIOM: “GPIO23”,4
+WIOM: “GPIO24”,4
+WIOM: “GPIO25”,4
+WIOM: “GPIO26”,4
+WIOM: “GPIO27”,4
+WIOM: “GPIO28”,4
+WIOM: “GPIO29”,4
+WIOM: “GPIO30”,4
+WIOM: “GPIO31”,4
+WIOM: “GPIO32”,4
+WIOM: “GPIO33”,4
+WIOM: “GPIO34”,4
+WIOM: “GPIO35”,4


#2

GPIO44 is now renamed as GPIO0.

Here is the exact response we received from wavecom support:

“Apparently, the GPIO pin was intentionally renamed to be consistent for our common firmware integration of WMP100, Q2687 and Q2686. GPIO44 has been renamed to GPIO0 for Q2687.
If you do a at+whcnf=2,x (0 or 1 to turn on/off), then you should see GPIO0 becoming available or not. And viewable with at+wiom=2.
(remember to do a at+cfun=1 after the change).”


#3

Thank you so much rajendrams.
GPIO0 is now working perfectly.