GPIO Problem


#1

Hi,

I have tried to control Fastrack (Q24X6) GPIO as output in every possible ways which I can image. I read thru this forum. No help.

This is what I try to do,

First:

s8 gpio1_handle;

gpio1_handle = adl_ioSubscribe ( ADL_IO_Q24X6_GPIO_4, 0, 0, 0, NULL );


then I try to control it,

s8 ret;

ret = adl_ioWrite ( gpio1_handle, ADL_IO_Q24X6_GPIO_4, 1 );
or
ret = adl_ioWrite ( gpio1_handle, ADL_IO_Q24X6_GPIO_4, 0 );

ret returns always OK. But, nothing happens in GPIO.

So, next I try control GPIO’s with AT+WIOW, AT+WIOR and AT+WIOM commands. Same result. No help.

What I’m doing wrong?

Could someone tell me what is GPIO correct electric connection? Should it be between GPIO and Power Supply + or - ? Or?

Thanks in advance!

/murjan


#2

Hi murjan,

Did you check the values for “gpio1_handle” and “ret”. If these are negative they contain an error code. Maybe that can help to find the problem…

Best Regards,
Jan


#3

Hi Jan,

gpio1_handle = 2 and ret = 0.

/murjan


#4

ret = adl_ioWrite ( gpio1_handle, ADL_IO_Q24X6_GPIO_4, 1 );

should be changed to

ret = adl_ioWrite ( gpio1_handle, ADL_IO_Q24X6_GPIO_4, ADL_IO_Q24X6_GPIO_4 );


s8 adl_ioWrite( u8 Handle, u32 GpioMask, u32 GpioValues );
u32 GpioMask - Mask of Gpios to write
u32 GpioValues - Mask of Gpio values to write


#5

Hi Tobias,

I have tried this also, same result. No help.

Could it be that GPIO’s works fine and software controls them, but I measure voltages from wrong place?

Does anyone know for sure how to connect fex. LED’s to GPIO?

\murjan


#6

I measure 2.8V between GPIO4 and ground when set to high, and 0 when set to low.

I don’t think the output can drive a LED by itself, but I’m not that into electronics so can’t say for sure.

If you still can’t set GPIO and measure high/low on it without any load connected to it, you should provide more information such as what firmware you’re using and what SDK version you’re using.


#7

Hi Tobias,

I measure GPIO’s like you told me. GPIO4 = 3.69V. GPIO5 = 0V.
All the time same. No matter what I do…

AT+WHWV:
Hardware Version 4.83

AT+WSSW:
a06_0zgg.Q2406B 0007006CAF5DC7FF

AR+CMGR:
651_09gg.Q2406B 1478872 070705 14:15

OpenAT v3.02

/murjan


#8

I was told that OpenAT 3.02/FW 6.51 is very buggy and should not be used.

I know first-hand that it contains quite a few bugs, but when I used it I’m decently certain that I had GPIO4 working.

3.69V definitely sounds odd though.

You should ask your supplier for SDK 3.03 if possible. 3.10 or 3.12 works too, but with those you may need modifications in your program.

Or check the hardware for any short-circuits that could affect the outputs, as well as make certain that you’re measuring the right pins… (pin 53 for GPIO4) and if possible, check on another module if the problem stays the same.


#9

Hi Tobias,

Thanks!

Short circuit it is not possible because Fastrack in boxed in factory.

I have tried this with three devices, same result always.

I ask from distributor newer version.

/murjan